prusa i3 calibration x,y,z

i have a prusa i3, used the calculator for calibration and got

ResultResolutionTeethStep angleSteppingBelt
80.00 Click to Share!12.5micron201.8°1/16th2mm

which is fine but which file and  where do i enter this information and how would the numbers be, like would they be 80.00  12.5 20 1.8 ect


  • You would enter 80 for steps per mm for the corresponding axis. If you have already uploaded a firmware you need to change it in eeprom using the hosts eeprom editor.
  • wow that was fast, where would i find the editor, did a search on the site but could not find it or is it somewhere on the configeration tool?
    and thanks

  • ok so i worked it out, but it slowed the y axis right down so much that it takes about 20 seconds to move a full sweep of the bed, so where it originly said 7mm, i tried 8,9 and 10mm just trying to bring the numbers closer but the y axis failed to move at all, on 9mm the x axis motor took about 1 second to make a full sweep although this was not touched in settings, gone back to 7mm so will try a diferent board but thanks anyway.
  • I think you are mixing things. The steps per mm can only have exactly one number so if you move 10mm in gcode the extrude rmoves 10mm. That is what you want to have. And it is easy to verify. Move 100mm and measure distance.

    Speed is a parameter you can increase, Decreasing steps per mm with same speed settings will slow down - but that is no problem if you increase the speed.
  • edited August 2015
    here is what i have been changing, its in eeprom.h
    #define EPR_MAGIC_BYTE              0
    #define EPR_ACCELERATION_TYPE       1
    #define EPR_XAXIS_STEPS_PER_MM      3
    #define EPR_YAXIS_STEPS_PER_MM      7    < this one, from 7 (original) tried 8 to 13
    #define EPR_ZAXIS_STEPS_PER_MM     11
    #define EPR_X_MAX_FEEDRATE         15
    #define EPR_Y_MAX_FEEDRATE         19
    #define EPR_Z_MAX_FEEDRATE         23
    #define EPR_X_HOMING_FEEDRATE      27
    #define EPR_Y_HOMING_FEEDRATE      31
    #define EPR_Z_HOMING_FEEDRATE      35
    #define EPR_MAX_JERK               39
    //#define EPR_OPS_MIN_DISTANCE       43

    go to 6 the z axis goes wrap speed and y disables, enter 7 or 8 and y axis disables and heat bed disapears from repitier host, go 11 and nothing happens with y but affects z, i must be doing the wrong setting but can not see any other, i have to set the scale of prints within cura before i print to x 0.8. y 0.8 and z to 1.0.
    in y axis-when i move back 80mm it goes back 100mm
  • edited August 2015
    also to add, x axis is the same, move 80mm, travels 100 although i have not changed any thing on this yet, however, Z axis is spot on, move 80mm and travels 80mm
  • edited August 2015
    went to delete this comment as was an edit but it would not delete so ignore this bit
  • also to add, x axis is the same, move 80mm, travels 100m although i have not changed any thing on this yet, however, Z axis is spot on, move 80mm and travels 80mm
  • ok,i noticed...... i upload the exact config h file from the original 0.91 firmware but placed with the upload config h uploader on the firmware tool in to 0.92, compiles and uploads fine, but the printer will not respond, all it does is go up in rapid numbers in the commands waiting window. add the config file to 0.91, changed steps per mm  from 100mm to 80mm in x and y as below, compiles and uploads fine, still prints the original size though.
    its a meltzi board on a prusa i3 printer.
    #define DRIVE_SYSTEM 0
    #define XAXIS_STEPS_PER_MM 80
    #define YAXIS_STEPS_PER_MM 80
    #define ZAXIS_STEPS_PER_MM 407
    #define EXT0_X_OFFSET 0
    #define EXT0_Y_OFFSET 0
    #define EXT0_STEPS_PER_MM 95

    tried changing it within eeprom but makes the printer do weired things
  • NEVER NEVER TOUCH eeprom.h!!!!

    When I say to change the eeprom settings I mean connect with host/server and open the menu EEPROM Settings where you see the set values and can change them.

Sign In or Register to comment.