Repetier Server with Hyperpixel 4 touchscreen?

Has anyone had any luck using the Pimoroni Hyperpixel 4 with Repetier Server?  The Hyperpixel install script works just fine on a standard Raspbian install, but for some reason when I run it on the Repetier Server Raspberry Pi image, the display refuses to work, despite the install script completing without error.  There's something in the Repetier Server image that disagrees with the Hyperpixel, but I have no idea what.  Any ideas?

Comments

  • Good question. We also are based on Raspbian strech light to have less unused software. We have openbox as window manager and start x server with login at end of pi users .bashrc file.

    I know from other frame buffer displays that they need to set a different target frame for x server in a fturbo... file. Maybe that is just what you are missing, so it still uses the hdmi output.
  • Anyone get this to work?  I'm trying to get this excellent display to work with a Pi 4.

    Same as above.  Installer seems to run, but black display.
  • As far as I see it is a framebuffer display. So it will not show what is on hdmi output which is programmed target of x server (framebuffer 0 /dev/fb0). Check if you have also /dev/fb1 which is your display. You must configure x to show it or copy fb0 to fb1 buffer. See https://medium.com/@avik.das/writing-gui-applications-on-the-raspberry-pi-without-a-desktop-environment-8f8f840d9867 for example. Might help understanding the problem. But don't have the display so never tried for a solution.
  • I am actually looking at that page right as you replied.  I'm pretty lost, but it looks like there are no fb devices (only the Hyperpixel connected).  I got it running on Buster, so maybe I can look at the fbturbo file to see how it's set up.

  • You mean the is only on /dev/fb... device on your pi? fb0 is the hdmi output. Our images are already on the newer stretch - so did it load the hyperpixel modules there?
  • I thought Buster was newest?  The Repetier-Server Pi image seems to be Buster.

    With a new Repetier Pi image and the HyperPixel installed (no HDMI connected) there are no FB devices in /dev.  With HDMI plugged in, there is only FB0.

    This thing is giving me a headache.



  • After 3 days and 1 broken screen, I finally got the HyperPixel working on a Pi 4 with Repetier-Server. It turned out to be a simple fix.

    Note, I'm using a wired Ethernet connection.

    Flash Repetier-Server to an SD card.
    Add an empty ssh file under /boot to enable ssh
    Put it in the Pi and boot it up
    ssh in, change the pi password.
    Install the HyperPixel 4 drivers: 

    curl https://get.pimoroni.com/hyperpixel4 | bash

    Choose option 1, Pi 4 with rectangular screen
    Yes when asked are you sure
    Reboot

    hyperpixel-rotate left
    Ignore the error message.


    sudo nano /boot/config.txt
    Add [all] and display_lcd_rotate=3 so that the end of config.txt looks like this:
    [all]
    dtoverlay=hyperpixel4
    gpio=0-25=a2
    enable_dpi_lcd=1
    dpi_group=2
    dpi_mode=87
    dpi_output_format=0x7f216
    dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
    display_rotate=3

    Reboot and Repetier-Server should come up on the HyperPixel.

    The sticking point turned out to be the [all].  The driver installer adds the other stuff (except the rotate) to the end of config.txt, but there is a [pi0] filter at the end of the stock Repetier config.sys that was ignoring the screen instructions.  Adding the [all] terminates the [pi0] filter and allows it to work.

    https://www.thingiverse.com/make:797369



  • You are right buster came after stretch. Thanks for the update. So the [all] missing prevented the overlay from being loaded.
  • That was it.  These are really nice screens.  And I learned a few things, too.
  • cosmith71 said:

    After 3 days and 1 broken screen, I finally got the HyperPixel working on a Pi 4 with Repetier-Server. It turned out to be a simple fix.

    Note, I'm using a wired Ethernet connection.

    Flash Repetier-Server to an SD card.
    Add an empty ssh file under /boot to enable ssh
    Put it in the Pi and boot it up
    ssh in, change the pi password.
    Install the HyperPixel 4 drivers: 

    curl https://get.pimoroni.com/hyperpixel4 | bash

    Choose option 1, Pi 4 with rectangular screen
    Yes when asked are you sure
    Reboot

    hyperpixel-rotate left
    Ignore the error message.


    sudo nano /boot/config.txt
    Add [all] and display_lcd_rotate=3 so that the end of config.txt looks like this:

    [all]
    dtoverlay=hyperpixel4
    gpio=0-25=a2
    enable_dpi_lcd=1
    dpi_group=2
    dpi_mode=87
    dpi_output_format=0x7f216
    dpi_timings=480 0 10 16 59 800 0 15 113 15 0 0 0 60 0 32000000 6
    display_rotate=3

    Reboot and Repetier-Server should come up on the HyperPixel.

    The sticking point turned out to be the [all].  The driver installer adds the other stuff (except the rotate) to the end of config.txt, but there is a [pi0] filter at the end of the stock Repetier config.sys that was ignoring the screen instructions.  Adding the [all] terminates the [pi0] filter and allows it to work.

    https://www.thingiverse.com/make:797369



    Thanks I had trouble until i read your solution. Thanks
Sign In or Register to comment.