3d View is Empty (new issue)

I've recently discovered a strange bug related to 3d view. I have quite old hardware - Nvidia Geforce 7600 GT, which supports OpenGL 2.1.2. I'm running it on a PC with Windows 10. If I run repetier host on a freshly booted computer - 3D view is blank, no matter what settings I set on my graphics card. However! If I run any browser before repetier host, it shows everything normally. Any ideas? I can live with that as soon as I realized the workaround, however thought that it might be interesting to devs...


  • First time I hear about this solution. Sometimes there is a problem if you have 2 cards and the "bad" one gets selected. Then power settings for correcty card sometimes help if they get set to be used always 100%.
  • Yes, and it is reproducible 100%. Running browser - 3d view is nice and running, close browser - 3d view gone. Tried IE, chrome, opera, ff - same. 
  • And if not started first it select the generic microsoft opengl driver I guess that does not work correctly due to old standard.
Sign In or Register to comment.