Unresponsive Z-axis end stop and wrong homing direction - K8200/Repetier

I've been having some issues with my Velleman K8200. It was working perfectly with Marlin until the firmware became corrupted. I've since installed Repetier Firmware and have everything working except for:
- the Z axis homing direction is incorrect (moves up when it should move down)
- triggering the Z axis end stop does not stop the motor

I'm certain all of the parts function and are wired up, as it was working with Marlin and I've been very careful to not change anything. I have sought help in another post here and have fixed everything else that was refusing to work.

Here's the details:
K8200 seems pretty standard hardware-wise
Has Arduino Mega 2560 and RAMPS boards installed
Has Repetier Firmware v0.92, controlled by Repetier Host v1.54 on Windows
All other manual controls except the ones listed above are working as they should.

I have read that crosstalk can be a problem. Does it sound like this could be my problem given the symptoms? If so, how do I go about confirming and rectifying this?


  • I think we're onto something here!
    So using the M119 command, and plugging and unplugging the endstop wires from the board, I can see that X and Y are responding correctly.

    X and Y both show value "H" when the endstop is hit, and when I disconnect it, but when it's connected and not hit, it shows value "L".

    Whereas Z shows value "H" all the time, whether it's hit, not-hit, connected or disconnected.

    As far as I can tell, it seems to occur no matter where X and Y are currently. So would I be right in assuming I have to figure out where my problem with the Z endstop is? I'm guessing I've got 3 possibilities - 1. it's connected to the wrong pins on the board, 2. the switch itself is faulty, 3. there's a problem with the wiring between the switch and the board.

    What should I check first, and how do I go about it?

  • Excellent! Found a continuity issue in the Z endstop wiring, resoldered all of the connections in the circuit and it roared into life!!! Woohoo!

    Thank you all for the help in solving this!!! Especially @Repetier for taking the time to answer my many questions on the previous thread.

    I fired it up to print a test cube and found it's printing askew (as in each layer on the Z axis it builds up has moved over to the right and back a little, so it's crooked). In any case, now that it's working again, I figure the rest is just tweaks, so I'll have a crack at that another day. Thank you all again! :D
  • Glad z axis now works.

    If skew is away from endstops it is normally crosstalk to the endstop. There is a aparameter ALWAYS_CHECK_ENDSTOPS which you can disable so crosstalk during print has no effect.
Sign In or Register to comment.