1.0.2 not working on my Mega 2560 and RAMPS.

I have multiple Mega 2560s, RAMPS and REPRAP DISCOUNT FULL GRAPHICS SMART CONTROLLERs.  I can get 0.92 to load fine, but there is no TMC2130 support.  I try to load 1.0.2 onto any of my boards and the LCD is just lit up and blank.  When I go from 0.92 to 1.0.2 the screen locks up and never reboots on its own, I have to power cycle and then it's just a lit blank screen.  I've tried changing many of the settings wondering if there is a configuration issue, but nothing helps.  Is there something with 1.0.2 that I did wrong?  I'm using the Arduino IDE to load the firmware.  When I go back to 0.92 everything works except my steppers that use TMC2130 drivers.

Any suggestions are welcome and appreciated.


  • I did not notice that you can switch to production 1.0.1.  That seems to be working so far.  Now to get my bed level sensor working.
  • I compiled it for Mega/RRD Full Graphic and it worked like expected.

    The sd card is using the same hardware spi that the TMC is using and 1.0.2 has new sd fat library with own spi access. That might be tge main source of the problem. I guess without explicit TMC support it is working?

  • It is currently working on 1.0.1 as downloaded from the site, but when it boots it says 1.0.2.  My main priority at this time is getting the z probe working.
  • Well I figured out why 1.0.2 would not load.  I had the SD card in when uploading the firmware.  I removed the SD card and it works fine.  I can insert the SD card and it reads fine after booting, but it will not boot with a SD card in the slot.
  • Hello @opy01!

    I'm the guy responsible for the Trinamic support. I've just tried to reproduce this issue using an SD Card slot connected to my RAMPS board and I cannot. It works just fine for me and I can start up the drivers with an SD card plugged in and read the card just fine.

    I want to understand your setup better so I can figure out what is wrong there. Can you please post your connections for the trinamic drivers. Most importantly, where have you connected the CS lines to?

    Better yet, post some pictures with the board and it's connections if you can.
  • It has nothing to do with the drivers, its my MEGA 2560, RAMPS and reprap discount full graphics smart controller.  The only reason I mentioned the drivers was 0.92 did not have support for those drivers and I needed 1.0.2 working.

    When I upload firmware 1.0.2 into my board while the SD card is in the slot, the screen is just blank but lit up.  As soon as I remove the SD card it reboots just fine.  I have not tried just powering up the board with the SD card in it.

    My other Mega 2560 and RAMPS won't load 1.0.2 at all.  It will load 0.92 though.  I just got another Mega 2560 in and will try it when I get a chance.
  • Out of the 3 working Mega 2560 boards I had, only 1 worked every time I uploaded 1.0.x.  That one just died.  I think either the USB burnt out or the main chip fried.  Had a power surge or something.

    I had a brand new Mega 2560 I just removed from the anti static bag and uploaded the firmware and the exact same thing happens where the firmware uploads but I have no display.  Now both of my only working boards have no display when using 1.0.x.  They both work fine with 0.92, but there is no TMC support in that version.  I've tried them both on 2 different LCDs and RAMPS with the exact same results.
  • edited May 2018
    I'm trying to make it work and narrowing it down.  On the original, if I had a SD card plugged in it would not boot, but once I pulled the SD card it booted fine then I could put the card back in and print.  On the one I am currently working one I can pull the EXP2 cable and the Repetier logo comes up, but it still doesn't boot all the way.  I think something is wrong with SD support on this version or on this model of display.

    I just got it to boot with 1.0.2 by unplugging the EXP2 cable then plugging it back in then unplugging it and when the logo comes up I plug it back in and it boots.  Its definately an SD reader issue, but I'm trying to figure out if it's the firmware or hardware since it works fine with 0.92.

    I just replicated this on the second Mega 2560 board.
  • This is absolutely insane!  Both of my RAMPS boards have back EXP2 solders.  I wonder if 0.92 was not using the specific pin or maybe it did not need as much power.  It's no wonder I had no issues from that one board, I must've had it in just the right spot until I fried it and had to swap it out.
  • edited May 2018
    Well, I thought I figured it out, but now I don't know.  I resoldered every single pin.  Now I'm wondering if it's a pin issue in my pins file...
  • I am slowly rebuilding the firmware from scratch.  I appears that when I enable pin D32 for my CS pin that is what is screwing up my firmware.  I have verified that PIN 32 does NOT go to any of the LDC pins on my smart adapter so I have no clue why when I unplug the EXP2 it boots up.

    There is nothing for motherboard 33, RAMPS_V_1_3, that has pin 32 in it.  I also just tried pins 47 and 57 that are not used anywhere else.  So I'm not sure if this is a pin thing or a TMC thing.
  • edited May 2018
    So back to your post above, now that I know it's a TMC thing.  This is all happening with just the RAMPS plugged into the Mega2560 and RRD full graphics smart controller.  No stepper drivers, no temp sensors, no heater.  It happens while plugged into USB or 12v.  I'm not sure how my other one was even working before it got toasted.

    Referencing your question above, it does work fine if I disable TMC support. 

    I did try disabling SD support while TMC support was enabled but I get the same results.
  • edited May 2018
    @opy01 Can you try out this version? https://github.com/alexsomesan/Repetier-Firmware/tree/improve-trinamic-init
    It has some improvements to the initialisation code that should make it more tolerant. I'm trying to also add log messages for the init code soon.

    Let me know if that version improves anything.
  • I'll try anything.  I have multiple boards to work with so I don't have to worry about taking my machine down... when it actually runs lol.  I'll let you know how it goes tomorrow.

    Thanks for your help and thanks for your patience while I work through all my little bugs.  Half are user error and the rest are either cheep parts or little things like this.  But I love experimenting and learning and helping out however I can.
  • Same results.  Upload with #define DRV_TMC2130 uncommented and it will not reboot unless I jack around with the EXP2 cable unplugging it or moving it enough to break connection, but as soon as I comment out that line again and upload, it reboots and works fine.
  • I just borrowed an MKS board and loaded the firmware on it and it booted fine.  It's something to do with the Mega 2560 and RAMPS 1.4 board combo.
  • @opy01 Can you share the exact branding on the RAMPS, the LCD adapter and the actual LCD board that you are encountering this with?

    I'm thinking to try and procure those and try to dig down into this.
  • edited May 2018
  • I bought a couple of kits.  This was the other one made in China instead of Italy.  
  • Tested Mega2560 + GLCD and it started normally with or without sd card. No components connected and no TMC2130.
  • edited May 2018
    Just so you know, I do not have any drivers plugged into this one when powering on.  It does not matter whether the TMC drivers are plugged in or not.

    I don't know if I'm just off base, but it looks like the Mega 2560 has SPI issues with SD cards anyway.  Not sure if this is the same issue though.  I thought it may be the display but it works on the MKS board that has a similar chip.  Maybe it's a hardware issue?  I keep going back to the fact that unplugging the EXP2 cable and pluggin it back in makes it boot.  Also my old board only worked if the SD card was removed.  So 3 similar boards, 2 identical RAMPS boards and 2 displays do the same thing.  I tried with my ANET A8 display, but never could get it working at all.

    Here is what I've found with SPI issues on the MEGA 2560 only but not other boards.
    https://forum.arduino.cc/index.php?topic=437494.0 (may not be relevant)
  • Sometimes it is a difference if you power up or reset as during reset the system is all well powered. Do you have same problems after a reset as well? In that case a increased pause before initializing sd card may help.
  • edited May 2018
    Hitting the reset button is just like uploading new firmware.  It just sits there locked up till I unplug the cable and plug it back in.

    I set this in the SDCard.cpp "HAL::delayMilliseconds(100); // wait for stabilization of contacts, bootup ..." and it is working now :smiley:!  It was set to 50.  I need to get it working on my actual printer though and it's taking a bit more.  I do have a RAMPSXB and a longer cable, if that makes a difference.

    Thank you so much for your help on this and thank you for coding better than me by adding notes to the side and above (I've never been good at that lol).

    Now to test it with the TMC2130 plugged in.

    Edit: I got it working on my big printer, but not with USB.  I have to power it on with a full 12v, but with as much as I have plugged into it I'm not surprised.
  • The mega boards have a 500mA 5volt regulator fitted as standard, fitting a full graphic smart display will run this regulator close to its max rating and can cause low voltage on the 5 volts rail, or even a regulator failure.
  • Ok that makes sense why one worked on USB and the other did not.  I installed a 1A regulator on the test one after it blew a month ago.  These things are super sensitive and the crap drivers that came with one of the kits all failed within a couple of weeks of each other and one of them ended up blowing the regulator on both my original boards.  I now have a board that refuses to boot, but still powers on and I test all my driver on it before plugging them into a good board.  If the regulator gets hot then I power off and trash the driver since they aren't worth the shipping to return them.  The other drivers with the other kit are all perfect and other than the steppers being a bit loud, they are rock solid.  

    Thanks again for all your help!  I printed last night and other than some slicer settings being off, it printed perfect!
  • Well I'm back.  For some reason it never quite worked right and I thought it was because I added more TMC drivers.  I've unplugged everything except the heaters because they are not running and are not even close to my EXP2 cable and I have no drivers plugged in.  I set the SDCard delay from above up to 2000 ms and it makes no difference.  This is so depressing to spend all this time and money and not be able to use it because it won't boot unless I unplug the EXP2 cable.  It's now in pieces again trying to figure out why it's doing this.  Any help is greatly appreciated!
  • I just ordered a new Arduino Mega, RAMPS 1.6 and RRDFGSC.  If it does the same thing, I don't know what to do.

    If you have not gotten one yet, what can I do to help out?  I love this firmware and do NOT want to have to switch back to Marlin.
  • @alexsomesan
    The new one did not work either.  It's something in the combo of the Mega 2560 and RRDFGSC.  I now have a spare.  Can I ship it to you so this can be figured out?  I know I can't be the only person that will come across this.
  • Hey Repetier,

    I also had issues with TMC steppers in the past using the stock repetier firmware.  I think the issue is with not making the pins SS, MOSI, SCK digital outputs in the firmware and setting SS low... ppl that use SD support don't have this issue because I see if you enable SD_SUPPORT the firmware sets these ports to digital outputs.  I found this out last night after adding TMC support to my heavily modified version of the repetier firmware (for milling).  4 lines of code and SPI works flawlessly.
  • Thanks for the info. Have added it to dev version. Also I just added 3 - do you think SS is needed where all drivers have own CS?
Sign In or Register to comment.