Hotend: Heater decoupled message, after finishing a print + setting new temp. (Wanhao i3, RAMPS 1.4

I recently changed the electronics of my Wanhao i3 from the Melzi to a cheap Ramps 1.4 (with separate mosfet for bed). Anything outside the control box was left as before.

I've created a new firmware based on the repetier configurator, using a Wanhao config file as base.

I've been printing several items now - all came out quite well so far. However, I've always printed them one at a time with significant delays in-between.
(i.e. print item, let machine cool down, print next item - the electronics is currently lying spread around my table and I want to make sure it doesn't overheat.)

Now I've tried to print two items in succession - every time I get that decoupling error. When I wait, I can print just fine.
Note: when I say "in succession", there are several seconds in between - enough to let the hotend cool down a bit, so I have to reheat it (sliced with Cura, I think it automatically sets the temps to zero after printing).

Is it possible the firmware doesn't realize I've set a new temperature?
Or is there perhaps indeed some overheating going on and I just don't realize it?

I don't think the extruder hardware is at fault, I didn't change anything there and it worked before and seems to work now.

(I suppose there are other threads like this? I didn't find anything useful in my search, maybe I was looking wrong :-/)


  • There is no fault i think. But your decoupling settings are too tight for the case cooling and switch to heating, See the log when it happens and you see which setting triggered it and you just need to relax the condition. So gibe it more time to raise or increase the variance allowed depedning on what you see is triggering and the problem does not happen again if set correctly.
  • Thanks, I'll try that.
Sign In or Register to comment.