Radds + 2x Adafruit AD8495 Breakout + NTCS0603E3104FXT


I am trying to run my RADDS 1.5 with two Adafruit AD8495 Breakout and a NTCS0603E3104FXT on the bed.
I Have wired both of the AD8495 to run off the 3.3V power source and connected the Vo pin to the temp in pins according to the RADDS documentation.
NTCS0603E3104FXT is wired directly to Temp 4 as per RADDS documentation.
The configuration has been tested in all combinations I can think of.

The problem I am having is that only Temp 2 works.
Measurments of both AD8495 show me that one reads about 0.03V and the other 0.04V.
On initial startup Temp 2 shows me ambient temp but Temp 0 shoots up to past the safe value and then reads def.
Thermocouplers I am using is Item# E-TYPEK-3X15-1000-SPADE from E3D.

Now regarding the bed.
Temperature is reading only reading 1.5 for some reason.
I have selected the correct sensor in the configuration and I have tested all pin combination to make sure I have selected the correct pin. But nothing I do gets it showing the ambient temp of about 20C.

I will be testing more things tonight. Like replace the thermocouple on Temp 0 just to make sure its not damaged or perhaps the wrong type.
Bed temp sensor will be tested while I heat it up just to make sure it doesnt have some kind of low temperature limit.
Other then that im kind of stuck.
Any help would be appreciated.


  • edited July 2017
    Ok, tested the Vishay thermistor.
    It's working, but there is a big offset of about 19C for some reason. I'm going to go back to the config to see if I missed something.

    Still no luck with the thermocouple. I even changed the sensor to one I had around and no luck.
    Seems like the voltage is not matching the expected 1.25V offset but still the Temp 2 sensor works fine.
    It's very strange.
  • Where do you connect them? RADDS has only one official pin at the side for the board. The thermistor pins can not be used for this as they share a 4.7K resistor in series so you have a voltage divide there.

    There are 3 more pins you can use if you remove the stepper driver on that socket. You can use these pins:

    // Due analog pin #59 = A5 -> AD 2
    #define THERMOCOUPLE_0_PIN  2   
    // There are no more analog pins freely available.
    // You can use direction and enable pin from extruder 0 socket as they are also 
    // analog pins. Then you need to move the stepper driver to a different socket.

    // Direction pin of extruder 0
    #define THERMOCOUPLE_1_PIN  1 
    // Step pin of extruder 0  
    #define THERMOCOUPLE_2_PIN  0   
    // Enable pin of extruder 0  
    #define THERMOCOUPLE_3_PIN  10 

  • So extruder 0 socket can be removed and the pins there used and if I understand correctly it's pin 0, 1 and 10 that are free?
    If so then I'll see where they are located with my multimeter later on tonight.

    Do you have any idea why the Vishay is showing the temperature offset? Seems like the table might be wrong to me.

    Thank you very much.
  • An update.
    Checking the pins it seems like Enable pin of Extruder 0 Stepper is pin A8 on the Arduino Due board.
    Similarly the direction pin of Extruder 0 Stepper is A6.

    So, im going to give this a try with the config. Repetier firmware config tool gives me the option to select Analog Pins and ill test with A8 first.
    Lets hope nothing releases the magic smoke :)
  • Ok, I did some testing, selecting the pin directly did not work but selecting the Thermocouple pins did work, but only for extruder 1.
    So, my conclusion is that the Adafruit board used on Extruder 0 must be defective. Ill order a new one and see what happens.
    Strange thing is, even with this Thermocouple config the Extruder 1 still reads the same valid temperature as when it was connected to the Thermistor input and if there is a resistor on that pin it should not have been the case since there should have been a voltage drop.
    I did do a resistance check on the Thermistor 0 pin to the Analog pin 0 and it shows 0ohm.
    After I get the new Adafruit board ill test some more.

    So, board temp.
    Still no solution on that. I heated the board but it still has a big offset so my conclusion is that the predefined Vishay NTCS0603E3104FXT must be defective or that I do not have any filters (capacitor or 5v resistor) on the thermistor since the RADDS specs did not specify it. To me that diagram seemed very strange since it is an analog input and the other pin is going to ground so I think there might be something going on there.
    Any thoughts?
  • Might have found the issue.
    But my board should be an original Due.

    Edit: didn't help.
    I'm ordering a proper due and a new adafruit.
  • Ok, I'm a bit confused by the data

    // Direction pin of extruder 0
    #define THERMOCOUPLE_1_PIN  1 
    // Step pin of extruder 0  
    #define THERMOCOUPLE_2_PIN  0   
    // Enable pin of extruder 0  
    #define THERMOCOUPLE_3_PIN  10 

    The comments tell exactly which pin. dir pin is marked on your stepper driver, step and enable often also and you can google it as all drivers with this socket use same pin layout.

    Thermistor 0 pin should be in series with 4.7K resistor. But on the other side the adafruit sends a voltage while thermistors are just variable resistors so the voltage divider can work. SO that is combing incompatible electronics and I can not really say what should happen then if you select the ADC pin. If you select the other pin you might produce a short in adafruit board as you put that voltage to 5v or gnd, not sure what is on the pin. Also can not say if that damages anything, but I would just prevent this.
  • Well, in regards to the Analog pins, I was looking at the Arduino schematics and checking the stepper pins to see what Analog pins were used just to make sure I wasn't doing anything wrong.
    That's where the confusion comes.
    The driver 0 pins are connected to the analog pin I said, I checked with the multimeter but I'm not sure what the firmware does if the pin is selected manually.

    In any case, something is wrong and I suspect it's the Arduino not sending the right reference voltage in regards to the thermistor issue, because I was ripped off with the fake arduino.
    The thermocouple issue must be a bad adafruit, perhaps I was just unlucky.

    In regards to shorts, I'm not worried. If there is a resistor in series then that will prohibit any short possibly created from adafruit sending voltage.

    In any case, it's still strange that thermocouple 1 works on any of the thermistor pins.

    One question.
    When you say that there is a resistor in series. Do you mean in series from the thermistor connector and the analog in pins?

    I'll update this post when I get the new items.
    Thank you.
  • If you check schematics you see

    GND - 4.7K - Pin to ADC - Thermistor - 5V
    GND and 5V may be other way around not sure here.

    The special ADC pin on the side goe sjust directly to ADC input, no other wires connected. Just like with the stepper driver pins.
  • Ok, parts replaced.
    New Adafruit, new Arduino Due.
    Bed now shows near the correct temp, about 10C below but perhaps there is an error amount or the table is incorrect.
    10C incorrect is still Ok.

    Now, to the thermocouple.
    Very strange results.
    The original Thermocouple 1 still shows correct.
    Thermocouple 0 either jumps up to 400+C or it sticks on 183C.
    Neither of them are correct, the strange part is that different ground pins give me the 183C or 400+C, I think there might be a solder issue with the spare ADC pin, but there is  no explanation  on the ground pin of the stepper since the stepper did work.
    I have tried to replace all cables, no change, changed the thermocouple to the Thermocouple 1, no change.
    Its very strange.
    Even when just changing the Adafruit board the new board just from package gives incorrect value.

    Could there be a version change in the Adafruit? Perhaps there is no 1.25V offset on one of them giving me the 183C instead of perhaps 21C?
  • Easiest way would be to power adafruit and measure voltage yourself. 

    Temperature = (Vout - 1.25) / 0.005 V

    Measure while connected to board and also when not connected to board. If it is unconnected correct it should also be when connected, but board connections might shift voltage causing firmware to show wrong value. Especially with the thermistor inputs this is what I expected.
  • What pin would you recommend powering the Adafruit from?
    I am thinking something in the way of the reference voltage is changing.
  • According the docs it does not matter as long as it is 3.3-17V. So you can use the Power pin at the side next to ADC pin. That is what I used for testing my implementation.
  • That's what I did also but it doesn't work for the first thermocouple, only for the 2nd.
    What about the ground pin, where did you attach it?
  • edited July 2017
    Ok, strange update.
    The one Adafruit is outputing 3.3V.

    This new one must also be broken, I can not explain it any other way.


    Edit:  Ok, I found the problem. The 3..3V issue pointed me in the direction.
    The thermocouple must be defective. When any of the Adafruits do not have a thermocouple attached they send out 3.3V.
    I swapped the Thermocouples around and then suddenly the swapped the temperature.
    Ill have a look at the thermocouple to see if I can fix it, else ill need to order a new one.
  • Ok, its confirmed.
    The thermocouple does not have a connection in between the leads.

    Ordering a new one tomorrow.
  • Ok that explains any strange readings.
    AUX ADC connector has 3.3V - ADV - GND so everything you need at least for one.
  • One thing that still bothers me is that the thermistor connectors did give correct readings.
    This leads me to believe that it might actually work.

    Ill do some measurements and see if there is any connection in between the 5V, Ground and Analog In that might make a difference.
  • Ok, everything fixed with the temperature.
    Bed is near enough temp.

    Now I have a new problem.
    Extruders are not spinning at all. Raps128 enable pins are inverted but still with the Click testing or Filament change the steppers dont spin at all.
    Steppers are fine, when I move them to X axis they spin fine but as extruders nothing happens.
    Im going to try to change the Extruders to some other driver, like X, but I dont expect it to work.
    I changes the steps per mm to a much higher value to no avail.
  • Ok, driver is fine.
    Moving X axis to Extruder 2 works fine, still the extruder doesnt rotate at all.

    Any ideas?
  • Try with
    M302 S1
    to allow cold extrusion for testing. Normally they spin only when hot. Open eeprom editor and see what is listed as steps per mm, acceleration etc. Wrong values there can prevent moves as well.
Sign In or Register to comment.