Anet A8 extruder thermo-sensor settings

I've got an old Anet A8 printer with no-name red Melzi v2 board. I've downloaded the official firmware, flashed, it works, but I want more flexibility and the newest version of Repetier! So I've downloaded the latest one (0.92.8), used online tool to configure it, flashed, and it sort of works... everything except extruder thermistor.
So, what we have:
* Thermistor works with the default firmware (tried to flash it again, still works, and doesn't work with Repetier). So the thermistor and mother-board both work, it's just a configuration issue.
* Thermistor is just the same as heatbed's one (type 1), which works fine in both firmwares.
* I've tried dozen of different options for thermistor type in config. It always shows either 0.0 or def.
* Tried to replace thermistor just in case - nothing changed.
* I've checked the board, the resistors for both heatbed and extruder thermistor are the same - 4.7k

I'm running out of ideas. What can cause this problem, what am I missing?


  • 0/def is when no thermistor is connected. So since you checked the type it most likely that you selected the wrong pin number.
  • Good point... Menzi v2 schematics says it's ADC7 pin, that's what I have in configs. Should I just try other ADC pins (7 of them total)? Can't it be harmful for the board?
  • Don't think making a output input does any harm as inputs are just high ohm input. Have you set it explicitly to Analog input 7 or used Tempsonsor 0/1/2?
  • edited August 2017
    Hm... makes sense.
    I've just used `TEMP_0_PIN` for extruder thermistor, which is set to 7 in pins.h for my board, which matches the schema I found here
    I'll try other ADCs (there are just 7 of them on ATMega1284p according to datasheet) in the evening.
    Thanks for help!
  • Didn't work :(
    I've tried all pins - 0 to 7. It's `def` for all pins except 6 (heatbed thermistor, works fine).
    Setting `TEMP_1_PIN` to 7 gives `def` for bed temperature. Setting `TEMP_0_PIN` to 6 gives good readings for extruder, but that's not what I want.
    Any other ideas? What other settings could affect it? What else can I try? I'm completely lost.
  • Ok, there is one other thing. Lets assume 7 would be the right pin. That analog pin has also a digital pin id which is most likely not 7, see melzi doc. If some other part of firmware is configured to use this pin as output it will not work as input and also return nonsense when reading input. So check your config for anything using the digital output pin.

    You can also run
    M105 X0
    to see the raw output measured which is between 0 and 4095. You should be a few 100 away from these edges or you get def.
  • Thanks for your help, but still no luck.
    Basically I've copied the latest git repo (master), uploaded boards/Zonestar P802M/Configuration.h to online wizard, modified some stuff, put the config file back and compiled. So the problem can be only in Configuration.h (and pins.h).
    I've checked every single line in the config - neither 7 or 33 is not found anywhere. 

    Here's my config file. The rest of the files

    Any ideas, what else can I try?

    Of course I can just upload the original firmware, but I don't like it, and I've spent 3 evenings to burn a bootloader to the board, I can't just give up :)
  • Ah, I know what can be wrong!
    I couldn't compile the code initially because of two places in Commans.cpp - lines 1616 and 1953 have `INPUT_PULLUP`, which is undefined for some reason. Quick googling suggested to just set it to 2, and that's what I did.
    Should I fix it somehow else? Can it be the case?
  • Thats for M42 and M226 which has nothing to with your problem if you do not call these gcodes.

    You should also check in pins.h if any symbolic name refers to 7/33 which is the last idea I have.

    You could of course write a simple sketch reading pin 7 and writing result to serial to see if you are hunting the right one. Since this sketch sets definetly no other pins it is good test for pin number.
  • Genius! Of course! I can just read pins 6 and 7 and check if the circuit is functional. Thanks for the great idea, I'll try later.
    I checked pins.h. All places mentioning 7 or 22 are inside other boards' definitions, so should not affect me.
Sign In or Register to comment.