Changed Processer ID?

I have a Prusa I3 clone with a Melzi controller that suddenly stopped extruding in the middle of a print. The motor is fine, I checked it out by changing drivers. From searches in the forums, it appears that this can be a corrupted firmware on the chip. So when I tried to reload the firmware, I get a message:

                  avrdude: Device signature = 0x1e950f (probably m328p)

                  avrdude: Expected signature for ATmega1284P is 1E 97 05

along with all the other information in the output. The board uses the ATmega1284p and that is set in the tools menu. How do I get the firmware replaced. I have tried raw avrdude commands which I used in the past to replace the firmware but the device signature matched then.


  • Are you using the bootloader to upload? There are 2 ISP connectors so when using ISP and you take the one for usb->serial it could be a different chip. But I never heard a chip has changed the id. So if using bootloader just try again or try with the melzi/sanguino uploader which is what I guess you need normally.
  • I'll see about the melzi/sanguino uploader. i did try several times with the ISP with the same results. When I use the raw avrdude commands I get all zeros for the device signature. I actually have 2 melzi boards and they both behave the same. I have made sure the power jumper is set properly and that there is power applied.
  • See also

    search for FTDI problems. If you have a fake FTDI depending on installed driver it changes data or does other nasty things. Not sure but could also be a reason.
Sign In or Register to comment.