Second Extruder Issues


This topic may be a bridge between Repetier Host and Repetier Firmware... Im not 100% sure yet.

So, I have upgraded my FolgerTech Cloner to a E3D Chimera dual extruder. I have PID auto tuned BOTH hotends, and updated the firmware and host to reflect the addition of the Chimera and the PID settings. In the firmware both extruders are ALMOST identical except for how its wire up, as in the ports its connected to on the RAMPS board.

Here is my issue.

When I print with extruder #1, it prints very well. It needs some very very minor tweaks, but it prints well. When I TRY to print with extruder #2, it heats the bed only to 50c, it doesn't heat the hotend, and goes about its day as if it IS printing. No extrusion or anything happening. My slicer (Cura) has only one print settings, and one filament settings. Both are set to default, and when I click "Slice with Cura" those settings are selected.

Is there something I am missing?

On a side note, when I print using the octopi server, I can get the #2 to heat up, but its not extruding properly and jams. I have tried an E3D v5, E3D v6, and Now the Chimera, and I get the same results with #2. There has to be a problem with my setup of the firmware or something.

Any help is GREATLY appreciated.


  • Maybe you have fan enabled. In RAMPS the FAN_PIN is also the heate rpin for extruder 2, so 2 functions struggling and modifying same pin can cause unexpected behaviour.
  • @Hotwire, Any ideas yet?

    I am seeing exactly the same issue with a few additional notes. When I run a dual-extruder project, it only heats the first extruder and begins the print with a cold 2nd extruder. I pause the print, enable the 2nd extruder manually and let it heat up. Then I continue the print and it prints properly from extruders. When it is done, it does not turn off the 2nd extruder.

    I am using Repetier Host 1.6.2 with Cura slicer and the printer is running 1.0.2-2 Marlin firmware.

    So, the printer/firmware seems okay. The Host software seems to ignore heating on the 2nd extruder, but otherwise recognizes it.

    I use to different extruder drives and, since Marlin does not support EEPROM settings for E-Steps for the 2nd, I add the following to the start script:

    G92 E95.3

  • Why the G92? It sets E position to 95.3 whcih makes not really sense to me.

    To disable extruder 2 send
    M104 T1 S0

  • edited July 2017
    Hi, I've installed the last version of Repetier Server-Host, so I've linked and set my dual extruder printer (Prusa i3) and sliced my project with the internal Cura Engine.
    I have the same issue of lancej:  extruder 1 and extruder 2 work only separately.
    If I print a double color project only extruder 1 reach the temperature but extruder 2 is cold.
    And why it starts to print if all the temperatures aren't reached?

    Before yesterday I had Repetier Host 0.95 and the double color print works fine.
    Thanks for your answers

    PS In my G-CODE I have only T0 command, no T1
  • CuraENgine does not enable or disable any extruder, so if that happens, when and how depends on the start/end script you wrote in CuraEngine settings. There is a button to create a default version as starting point.
  • The line activating T1 is missing
    You can edit the gco file manually with notepad adding M109 T1 S200 ( or the temperature you need) next to the T0 Line
  • Check the start gcode in curaengine config, it should have a line like this:
    {IF_EXT1}M109 T1 S{TEMP1}
    to enable it if that extruder gets used.
  • Exactly. That line is not there by default. Adding it to your pringting profile will activate second extruder. At the end of the day is G code
  • It is only in start code when you hit the create default gcode button after having set extruder count correctly.
Sign In or Register to comment.