Unknown command

Hi All

Facing a strange problem.

I have setup my delta printer and using Arduino mega and ramps, Repetier 9.2.9 version of the firmware

The test files were printed perfectly fine.

When I am trying to print some STLs the printer stops suddenly it gives the following msg

20:03:45.326 : ok 2794
20:03:48.419 : Unknown command:N56283 G-1029 T13  X0.00 Z0.00 F0.05 S1448498774 J0.00 R-0.00??????????????????????????????????????????????????start
20:03:48.434 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000

Please help


  • Strange thing.That is in deed an unknown command and it seems to crash the firmware in addition as I see it reset.

    Just to be sure - when you say printing STL files you have sliced it into gcode and you are sending the gcode, not the stl file, right? 

    Normally it is not possible to send such commands as they include a checksum to prevent garbage to be interpreted as correct gcode. So what software are you using to send the gcode? Does it print a while an dthen get this error or happens it right at the start.
  • It shows a behavior of stopping any time during the print. I am bringing the STL file in repetier and slicing that with slicer. Then print.
    It prints a while and then stops.
    Is it that the ramps or arguing mega has less memory? I also tried to change memory in the printer settings. But it's same. The test files that are very simple or small are still completing. Using feed rate 50% and printing slow.
  • I guess you mean receive buffer, but there 127 is ok. That is what you have.

    If you have a delta printer it would be important to have at least 900 byte ram on printer board ram. Arduino shows this after compilation what you have. If you don't have strange things can happen as you can run out of memory.

    As transfer protocol select "Force binary" so it always has the good checksum computation.

    Also how is your error rate in communication?
  • edited April 2017
    Yes you are right. I meant receive buffer. When I compiled the sketch, following msg was displayed :

    Sketch uses 129140 bytes (50%) of program storage space. Maximum is 253952 bytes.
    Global variables use 7390 bytes (90%) of dynamic memory, leaving 802 bytes for local variables. Maximum is 8192 bytes.
    Low memory available, stability problems may occur.
    That means I am low on RAM 
    If that is the case then how can I increase RAM 
    Should I use another Board that has faster processor and more RAM such as RADDS?
    Eventually I have a plan to use 5extruders with a mixing color.

  • Ok, 802 is not 900 so that might be the problem. While RADDS is always a better choice on deltas, you should first fix it on your 8 bit board. Reduce DELTASEGMENTS_PER_PRINTLINE until you have enough free ram. In config tool only visible in expert mode in mechanics tab.
  • Thanks 
    Is there a way to change in EEPROM or other way 
    My firmware has several changes after compilation. 

    Changing to DELTASEGMENTS_PER_PRINTLINE to 22 seems to have around 1012 bites free for local variables. 
  • DELTASEGMENTS_PER_PRINTLINE is compile time only. In host and server you can backup your eeprom settings to disk. Always a good idea if you have modified them.
  • Thanks
    Problem somewhat solved as the spool holder printed without problem. Do you suggest that I should change to radds with extension board. I am planning to have a 5 color diamond hotend. Then I'll have 8 stepper motors. X Y Z and 5 extruders. Or would you suggest any other controller ?
  • For deltas I always suggest due boards as they allow 600 updates per second and still allow higher speeds.
    RADDS with extension board would maybe the best solution I know with 8 ports. 
Sign In or Register to comment.