DeadTime control bed too hot?

Is there anyway to adjust the dead time control so that the power to the heating element is not cycled as quickly or the on time is less or limited?

I have a relay driver 110v heater in a large mass AL plate...this is great for making even heat and heats reasonable fast.
I calculate based on the Repetier instructions the dead time is about 50 seconds.

However what I find is even with long dead time the heater cycled every 10 seconds or so and stays on for a few seconds or longer even after
the thermistor reports the bed temp is over the set point.  Presumably the firmware thinks the temp is dropping and is trying to catch it up before it goes too far below the set point.

What happens is I set the bed for 70 degrees the heater comes on full and stays on until the bed reaches about 50, it then cycles quickly on and off as the bed reaches 70, however it then continues to cycle as the bed passes 70 and goes to about 73 or 74 but then never sinks back to 70 but remains at the higher temp and keeps cycling on and off.

Now normally this would not be a problem but what I find is because the bed cools slowly which I like it often doesn't get below 70 before I am ready to start the next print.  If the next print again sets the bed to 70 the print will never start as the bed stays at 73 and never enters the sweet spot I have set +_2 degrees.  I could widen the tolerance to +-3 or 4 and that might do it, but then the print may also start at 66 which is a bit cool for the first layer.  I could also try to set the last layer of the first print to something like 65 so that the bed can cool as the print finishes but most prints don't last that long and I don't want detachment during the last few layers (probably not a problem).

 A better solution would be that the dead time have some sort of adjustment, maybe even self adjustment as it observes the temp never reaches or drops below the set point, or some method to reduce the time it spends on.....kinda back to a PWM style control I guess...

Maybe I missed a setting?

Any suggestion how to get and keep a stable lower temp or maybe one that bounces from 69-71 with this type of setup?
PID won't work since I use a relay setup correct?
Bang Bang might be the way but I recall some issue that pushed me to try the dead time...
And dead time has been good a little warmer than the set point but not a problem it is just not ideal
in my current print clear and print again process.



  • Dead time control may not be best choice for heated bed with such a long duration it will deviate easily and is hart to adjust.

    Regarding your relay (SSR I hope) I would suggest using "bang bang every x seconds" where you can set a minimum time to enable/wait causing less switches. Heated bed is not that critical for printing that 1°C more or less matters.
  • edited February 2017
    Well I spent some time working with the different heat controls...

    I am at a loss how to set the "bang bang every x seconds" I can set "bang bang" and "bangbang slow" but to sure how to set the "every x seconds" parameter....

    With the default for those two choices my bed gets way too hot overshooting the set temp by 10-15 degrees and then cooling to the set point and overheating again.

    I returned to dead time and that does a very good job holding the temp constant, it just holds it 5% too high.

    Maybe this is just something in my bed heat setup....but it seems like if I could reduce the total time the heater is on when it is cycling in dead time mode I could tweak it down.  For now I am using a combination of a wider bed temp band and a reduction of the temp during the print to work around my problem of the printer never cooling enough to start the next print. 
  • there is a simple way to prevent beds with a big mass from overshoot. put temperature sensor close to heating element.
    (my heatbed is 400*200 mm , 12 mm thick) i use pwm for temperature control and it works like a charm.
  • Thanks for the input,

    My bed is 300mm diameter 15mm thick AL plate with an embedded 110V 1200W AC heating element...I can't use the PWM with this setup (it is driven by an SSR) nor can I really reposition the sensor in a better place...It is currently in a small insulated depression in the center of the bed, pressed against the bottom of a 1/4 inch glass plate.  This is the flatest non warping bed/surface combo I have come up with and in that respect it works well.

    I played with the dead time control and I found too much or too little dead time both result in overshoots and worse prevents prints from starting.  After a some trial and error I have found that about 45-50 seconds of dead time will keep my bed at 71 vs the 70 set point (I would like to have found a way to get 69 as that would allow a smaller band for the print startup but might have caused other issues.)  So for now as long as I allow a 2 degree window on the bed then I am good and pretty much spot on the temp I want....not sure how well that will play with different temps but I'll deal with that when it comes up.

    As a side note I am unclear or rather the instructions in the configuration seem unclear as to where to set the allowable window for the bed heat vs for the extruders...I like my extruders to be spot on and a few seconds of settle time, the bed needs that 2 degree window and similar settle time would not hurt and if set a bit long helps heat the print chamber.
  • One problem with dead time control is that it assumes same timing for heating taking effect as for cooling down. You normally adjust this with pwm value for heating period, but that is fixed to 255 due to using SSR. I still think that this is no real problem for bed. What you measure is not the real temperature anyway. Have a 20mm AL plate and I know how long it takes to heat up and cool down. If your sensor is near heater it will change more quickly but on the top surface these changes do not come through as good. It will even take some time to get that 70°C when the bottom has already reached it.
  • edited February 2017
    yes, things are working Okay in reality, I have no problem with the actual print using temps I get.

    The temp issue is only a problem on the second or later prints.

    My problem is that subsequent prints can't start.

    This is the sequence of events....

    printer starts at room temp
    Start first print job: bed heats up....set to 70...this is fine and the print starts.
    During the print the bed is held at close to 70,  about 73-74 according to the printer which is fine real or not it is what works.
    The print finishes and I remove it from the bed.
    With the bed temp now set to 0 the bed remains 73ish due to it's thermal mass it will take some time to drop below 70.
    I setup and start the next print job which also has a bed set temp of 70.
    The command goes out to heat the bed to 70 (waits for 70), however the bed has only dropped to 72 or 73
    Bed heater begins it's cycles and bed returns to 73-74 degrees
    Bed never reaches 70 (It is always hotter)
    Print never starts....waits forever to reach 70...

    One solution is obviously wait for bed to cool before second print
    Another is to use the printer controls to tweak the bed set point up to the actual bed temp then back down the print will start.
    If the print job is long enough put in a lower bed temp an allow the bed to cool some during first print so it can reheat on 2nd
    Set the acceptable band where the bed set point is ignored to something like 3 or 4 degrees so the print can start with 73

    What I was hoping for was a way to keep the bed at closer to 70 like +-1 so the band where the print starts is smaller.
    (maybe +-4 is fine but that is now 8 degrees bigger range than desirable... also for some reason the firmware seems to
    apply this same +- range to the extruders which is more of a problem, but I think this is a config issue on my part just not sure where to make the change so the bed has the bigger +_ range and the extruder has 0)

    I have worked around this to some degree by using a combination of things but not arrived at a solution that always works,
    except the long wait to cool.

  • For the bed I see no real solution. What I do with my massive bed is never put heated bed into gcode. I start it manually before starting a print and start when I think it is warm enough. Not elegant, but with your restrictions and available controllers the only option. Only bang bang could solve it if you want no PWM.

    For extruders it is possible as you can reduce PWM for heating here. That way you can equalize heat and cooling speed, whcih is the main reason for not getting it to stay at set temperature. It simpüly starts heating too early with too much heat so it overshoots all the time. Or time is too long. After all when it starts cooling and it sees I'm in deattime at target it starts heating.
Sign In or Register to comment.