Why does Repetier Host display a blank white screen in 3D view?

I just installed Repetier Host and I can't get a 3D screen to display. It is a blank white screen on that side of the window. It works fine on one of my computers running Windows 8, but on the one attached to my printer is does not. Any suggestions on what the problem could be?


  • That is most likely a problem with OpenTK and your opengl driver. Next release gets a newer version of opentk that is known to work with more drivers and hopefully fixes it. For now you might test installing host with legacy OpenTK version instead which works on some drivers the other version does not work.
  • Thanks for the response. How do I find Repetier Host with legacy OpenTK version? I checked (and searched) on the Repetier website, but I couldn't find anything that seemed to be it?
  • I did further searching and found the legacy version. Trying it now. Thanks!
  • The legacy versions on your website didn't work. Back to the drawing board for me. I'll have to see how to get around this obstacle.
  • Hi I have this problem too. plz help if you found a way.
  • Please try our beta. It uses a newer OpenTK version that was reported to solve such problems on newer drivers


    Note that it is in development but should be stable for printing. Only some new features are not working 100% as supposed.
  • I had the same problem and I solved it in the following way. 

    First a bit of background about my setup. My computer that I use to connect to my Delta printer is a Lenovo T61 (actually Frankenpad). The graphic chip in the laptop is GMA965. Instead of using the standard graphic driver that comes with Windows 7 x64 I tried to use a modded Intel graphic driver as it delivers better performance (Chell v1.8b). I had the same problems with Repetier Host v1.6.2, with the new graphic driver the 3D view was showing as a black area. The same issue is described in the following thread: https://forum.repetier.com/discussion/1226/3d-view-only-showing-a-black-screen. At that moment I kept the old graphic driver (from Windows 7) in order to be able to use Repetier Host on my machine.

    I installed the new version of Repetier Host v2.0 and I had a white area in 3D view. My conclusion is that the Intel modded driver installed on the machine is causing the problem. The solve the problem you need to:
    1. go to http://trixarian.co.za/forum/showthread.php?tid=1 and in the first post there is a link for MESA OpenGL Software Renderer.
    2. download the MESA OpenGL and unzip it. Inside there are some files opengl .dll for x86 and x64. Copy the corresponding version of the file to the folder where Repetier Host v2.0 is installed.
    3. start Repetier Host and everything should work fine, the 3D view area should be shown correctly. 

    Probably this solution works also for the old version Repetier Host v1.6.2, but I did not test it.
  • Nice! same problem as described! Solved as described!
Sign In or Register to comment.