3d view only showing a black screen


I'm using Repetier 1.5.6 on W7, Lenovo T60, OpenGL 1.4 (with rendering disabled unchecked) and it was working fine a few weeks ago, but now I opened the program and in the 3d view area it only shows a black area.  When I click on Temperature, it shows that, but clicking back on 3d view, it will only show the temperature screen, or a black area.  Log at the bottom of the screen shows no problems. 

I've also had it do a few unexpected crashes or not responding window popups while trying to troubleshoot.

Scanned for viruses, and that was nil.  Did a windows security update last week, but can't see why that would do it.  Checked for any other driver to be updated and that was also nil.  Uninstalled and reinstalled the program, but that did not fix it.  No other changes or new additions made to the laptop.

Any ideas?


  • Have you reinstalled it? 1.5.6 comes with 2 3d library versions. If you reinstall try using legacy 3d library instad. Maybe that helps.
  • Yeah that fixed it, but I did not install it that way before, and have no idea why it would suddenly change on its own?
  • If I'd understand this I wouldn't bundle 2 versions :-) This all depends on graphic card and drivers installed and color mode selected.
  • One other issue happened, the new local web server software blocked the usb communications between the Repetier host program and the Arduino.  How do you disable the server from always starting when Repetier starts?
  • Idea is to select repetierserver as connector in host.

    If you want it not connect, set printer to disabled in webfrontend, then it does not automatically connect, only after you reconnect.

    In windows services you can change the start behaviour to manually so it does not start autamtically, which I wouldn't do.
  • Having exactly same problem on HP Compaq dc7800 mini tower running win7 64bit. This is a new Repetier install. Repetier log shows - Open GL 1.4.0. - Renderer Intel Bear Lake B - Using Fast VBO's is possible. Uninstalled  Host 1.6.1 & Server and re-installed again using legacy drivers, and still not working. Tried compatibility mode, still not working. Everything else seems to be working fine. Slicer & display working good. Be my luck Repetier does not like display card on this unit (but works real well on Imac install).
    Anybody suggest solution?
Sign In or Register to comment.