X and Y offset in firmware

I'm new to the software as well as 3d printing, I have a printer with dual extruders. I have made x and y offsets in Slic3r to make the print right but in Repetier it looks offset but prints right. How do I adjust it in the Firmware so I can go back to 0 in Slic3r offsets?


  • You simply enter the same value into extruder offset for x and y. Only be carefull in eeprom unit is steps so if you have 80 steps per mm take value * 80. Then make sure in slic3r and host offsets are set to 0 since now firmware takes care of it. So you only need to adjust there and no recompile if they mismatch is needed.
  • I brought this thread back to life as my question is related...and keeping the answers together seems like a good idea.

    My printer is.a delta...

    I have dual extruders, both offset along the Y axis.  I leveled the printer quite well with extruder one before I enabled extruder 2, although it was always installed and skims just above the prints made by extruder 1 as desired.  When I went to try using extruder 2 I first just put in the offset from extruder 1 in the firmware......this worked okay...but I wanted to maximize my print area and wanted to split the offsets between the extruders so one was positive the other negative.  So if the distance between them is 2000 steps then Ext1 would be -1000 and Ext2 would be 1000.  This would center the effector over then bed....

    But something odd happens when I try this....the nozzles now ride several mm above the bed and are not completely offset from each other correctly...this seems really wrong compared to more normal operation with just the second extruder offset by a positive number.

    Maybe this has to do with how I calibrated the bed but I don't see how.  While I did get everything flat knowing that EXT1 was offset from center the whole effector plate seems to move flat so I don't think this is some effector tilt issue....

    Any Ideas?  Maybe negative extruder position offsets are just not allowed?


  • Deltas are a bit special regarding offsets because the move functions are all nonlinear. Functions use effector center for positioning and for that reason all extruder offsets MUST be relative to effector center. I have the same on my delta and it is no problem to have negative and positive values. 

    Since you had it working wrong, I guess your calibration caused a difference that you now see. You fixed the error with some adjusted calibration parameter. Remember it was at negative position but you calibrated delta for it as it was on center which requires a different move. So fix offsets and adjust zlength and see if it works better then.
Sign In or Register to comment.