Temperature sensor E3D Extruder not working

We are upgrading one of our printers (with multiple extruders) to newly purchased E3D Revo Hemera 24V (https://e3d-online.com/products/revo-hemera-xs) extruders. When installing the heatblock and temperature sensor and after changing the EXT0_TEMPSENSOR_TYPE value in the firmware to 8, we get negative values on all extruders ... 
I have tried all solutions that can be found online, but nothing seems to be working. Do you have any suggestions for solving this problem? 

Thanks in advance!


  • Did you measure resistance of your thermistors before connecting? negative and very hot mean you have a short or no connection at all normally as it is the extreme adc converted with temperature table. At room temperature measured at the (disconnected) pins you should measure around 100kohm if they work as expected. Make sure pins also have contact.

    As counter test you could just connect old sensor cable and see if you get a temperature. If so firmware is at least working correct and it is resistance/contact with new one.

    If it is wrong with old sensor - did you use correct configuration - meaning the old working one or did you create a new one and made some config errors so it does not match printer. Or even simpler connect thermistors to other analog pins then originally?
  • It's negative, but the hotend aren't heated... The default "room temperature" value that the sensor gives back is around -8 to -5 degrees celcius. 
    Today, we conducted a test where we connected the old sensors (it's a different type of themistor) back to the printer, and they worked as expected, giving correct reading on temperature and heating. 

    So are you suggesting that there is something wrong with the connection between the pins of the thermistor and the motherboard? 
  • The typically used thermistors have 100kohm at 25°C so all show nearly same temperature regardless of type. Since that works with old and new one does not ant the ATC sensor has minimum -40 in table it reems to have some resistance.

    But are you sure it is a thermistor and not a thermo couple? Thermo couples like PT100 and k-Type need a different electronic to read temperatures. I know they sell amplifier boards
    so it might be a different sensor type. Unfortunately the page you link does not tell the sensor type included. Only 300°C which is quite high for thermistors.

    Note that the thermistor pins are in serial with 4.7k resistor so can not be used for amplifier boards. For these you need a pure ADC input pin.
  • In this guide, E3D suggests that it is an ATC Semitec 104GT-2 sensor type. Because they set the senor type to 8 in the firmware for the extruder, based on your information in this thread
  • @Repetier any suggestions on the provided feedback above? Thanks in advance!
  • If it would be a ATC Semitec 104GT-2 sensor then it is correct. Please measure resistance as proposed already to verify that. This was a year old and they might have changed the sensor or there might be different versions. At room temperature all will show around 25°C and if they don't they are normally defect or no thermistors.
  • I measured the resistance of the thermistor and it showed a value of 97.4 kΩ and based on the things I found about this sensor type, that's expected. Or do you have other input concerning this reading? 
  • That reading is ok for thermistors at room temperature. So ATC should at least show room temperature.
    What board are you using and where do you connect it? Since old sensor works did you measure it as well - just to rule out that the old one was thermo couple:-) After all if both are 100kOhm why should one work and the other not. That is what is confusing me most on your problem.
  • We are using a Stacker Superboard 32-bit. It's custom made by the supplier and it is also custom firmware, modified by the supplier to fit their own needs so I don't know if it is helpful to tell you where they connect. 
    For the old sensors, the firmware was configured to use EXTX_TEMPSENSOR_TYPE 13 so it's a different type of sensor than the ones we are currently using. 
    The resistance measurement for this old sensor is around 110 Ohms (not kilo...).
  • I wrote the custom changes, so I know:-)

    They love PT100 for more robust answers and type 13 is just that a PT100. Youse that instead if you can. If you want the ATC you need to use the thermistor pins to the left of the thermo couple pins you are using now.

    Here the pin names and numbers for the superboard:

    #define TEMP_0_PIN 7
    // These pins are for bed !
    #define TEMP_1_PIN 6
    #define TEMP_2_PIN 5
    #define TEMP_3_PIN 4
    #define TEMP_4_PIN 3
    #define TEMP_5_PIN 0
    #define TEMP_6_PIN 1
    #define TEMP_7_PIN 2

    #define THERMOCOUPLE_0_PIN 10
    #define THERMOCOUPLE_1_PIN 11
    #define THERMOCOUPLE_2_PIN 12
    #define THERMOCOUPLE_3_PIN 13
    #define THERMOCOUPLE_4_PIN 14

  • Do I need to physically switch pins on the superboard or are they already connected?
    Do I need to switch numbers and/or pin names in the firmware or?
  • You need to change pin in firmware config and physically! So if it was THERMOCOUPLE_0_PIN and TEMP_0_PIN is unused you could connect it there and need to set the pin to TEMP_0_PIN in configuration so both match again. Then reading makes more sense as thermistor inputs are in series with 4.7k resistor there as expected.
  • How do I locate the pin location/number on the board? There are not a lot of pins left so ... 
    Sorry for the difficult and dumb questions maybe but I'm trying to make sense of this, I'm not a firmware developer. 
  • See image where the pins are:

    They are also named on the PCB

    If one does not show temperature just try next pin if in doubt. The one that starts correct readings is the one you want. Just make sure to only use these 2 header blocks. Actually the left one for the ATC sensor.
  • I found the first pin quite quickly, but with the rest I had some issues. Due to the fact that a component on the controller board broke a couple of days ago, they had to rewrite some firmware at the supplier and we had to connect the heater connections for extruder 1 to another part of the board. For this, we had to create some sort of jumper to insert on a certain pinset on the board. You can find it in one of these links: https://ibb.co/bQcbKq3, https://ibb.co/x28vmj9 ... apparently, I had to create jumpers for all heaters now and now, the heating and temperature readings work perfectly. Thank you so much for everything and for your support!

    Now I'm struggling to calibrate the extruder steps/mm. According to E3D, it has to be set to 397 mm/s for this particular hotend/extruder motor. I did this, but it wasn't extruding as expected (using the well-known measuring method to calibrate your E-steps). I adjusted the steps a couple of times, but sometimes it extrudes too much, and the other times it extrudes too little, even when using the same steps/mm in 2 tests. It's very inconsistent, even when using the same E-steps value. 
    Is this something you could pinpoint of where the error for this could be?

    Again, thanks in advance!
  • Use slow speeds for calibrating extrusion (1mm/s) and make sure heat is really good. If you test/extrude too quickly filaments does not melt fast enough causing more back pressure and causing slipping or loosing steps in extruder drive. And of course steps always depend on microsteps of motor so if you are off by a 2^x factor it is microstep related. Except if you are using stacker drive - then you can forget their value as they might have different diameter in drive resulting in other steps/mm.
Sign In or Register to comment.