Firmware update on RepRap Melzi v2.3 board, SD card issue, probable pin misassignment

Its an Aurora 3d Z605 model, chinese.
Stock firmware v0.91.
Arduino IDE Board info:

BN: Unknown board
VID: 0403
PID: 6001
SN: Upload any sketch to obtain it

I found a Configuration.h on reprap forums, used it with the repetier online configuration tool, got my Repetier firmware master and in Arduino IDE with "Sanguino" by Kristian Sloths I tried to flash it. After a baud rate config I could flash it, using the usb cable that normally connects the printer to the pc, no jumpers adjusted. 
Now M115 reports firmware 1.0.4.

ok 0
Printed filament:515.12m Printing time:5 days 3 hours 27 min

Every time I connect I see this message:

Printer is now online.
Detected EEPROM version:20
Z jerk was too low, setting to 0.70
Free RAM:12130
SD init fail
SD initialization failed.
Do not reformat the card!
Is the card correctly inserted?
Is chipSelect set to the correct value?
Does another SPI device need to be disabled?
Is there a wiring/soldering problem?
errorCode: 32

Repetier host would reset the printer and go into homing and reset and homing etc...
Pronterface allows me to connect, movement works, hot end works, bed heats up (enable it in the web firmware config tool). 

error Code:32
How to fix this?

Thank you.


  • First is a sd card inserted into board? I think you have configured sd card detect pin. If you have no sd card inserted, you need to invert the card detection logic.

    If a sd card is inserted it fails to read the sd card. Firmware can only read FAT and VFAT format. Here first test is remove sd card and retry. Then check sd card format and make sure it is not too big. Not sure which sizes it can handle. 
  • No card inserted at and I am mainly using this 3d printer with the usb cable.
    The message about SD card is displayed on connect/reset. I am learning 3d printing and havent used the sd card at all.

    About the SD card suport, its mainly in "Features" tab, right? (firmware config web tool)

    I have to check box on the:
    "Enable sd support. Gets overwritten by ui-controller or board settings."

    Then select one of the dropdown menus on  
    "SD card detect pin"
    where are 2 options with "SD" in them "SD card detect pin if available" and "SD slave select". 
    And then "Invert sd card detect signal" if needed.

    I think i have tried all combinations of those with the invert checked or not.

    In the board that I have the sd card is read by the HC541 ic, 20pin small package. I tried to look the pcb but its black and hard to see the traces between Atmega 1284p and HC541 

    Also this "Z jerk" message, its always "Z jerk was too low, setting to 0.70"
    I change it in "Mechanics" tab to 0.7, 0.8, 0.85 and it just displays the same message on startup.
  • As a first try just disable sd support. There is no ic involve din sd reading, just a passive housing for sd card connected to spi pins. So hope that is just the name of the housing.

    After first upload new values are not copied as they are stored in eeprom. Send
    to reinit with firmware values or just use eeprom editor to change them. Message is not that important as firmware just tells you it did the required correction already for you.
  • Thank you. 
    I did uncheck the SD support in firmware config tool. Looks like it does not change anything. Still reports SD issues.
    Flashed, connected and sent M502 then M500.
    At the very least I am getting a hang on configuring my table as I want it, so I can max out the printing area. 
    This is my log at connection:
    13:33:39.169 : start
    13:33:39.185 : Detected EEPROM version:20
    13:33:39.185 : Free RAM:12076
    13:33:39.665 : SD init fail
    13:33:39.665 : SD initialization failed.
    13:33:39.665 : Do not reformat the card!
    13:33:39.665 : Is the card correctly inserted?
    13:33:39.665 : Is chipSelect set to the correct value?
    13:33:39.665 : Does another SPI device need to be disabled?
    13:33:39.665 : Is there a wiring/soldering problem?
    13:33:39.665 : errorCode: 32
    13:33:39.665 : SelectExtruder:0
    13:33:47.477 : X:-30.00 Y:-8.00 Z:0.000 E:0.0000
    13:33:47.477 : DebugLevel:6
    13:33:47.478 : SelectExtruder:0
    13:33:47.479 : Begin file list
    13:33:47.479 : End file list
    13:33:47.493 : Cap:PROGRESS:0
    13:33:47.493 : Cap:AUTOREPORT_TEMP:1
    13:33:47.493 : Cap:HOST_RESCUE:1
    13:33:47.493 : Cap:EEPROM:1
    13:33:47.493 : Cap:AUTOLEVEL:0
    13:33:47.494 : Cap:Z_PROBE:0
    13:33:47.494 : Cap:SOFTWARE_POWER:0
    13:33:47.494 : Cap:TOGGLE_LIGHTS:0
    13:33:47.494 : Cap:PAUSESTOP:1
    13:33:47.494 : Cap:PREHEAT:1
    13:33:47.494 : Cap:EMERGENCY_PARSER:1
    13:33:47.494 : Printed filament:515.15m Printing time:5 days 3 hours 29 min
    13:33:47.494 : PrinterMode:FFF
    13:33:47.495 : X:-30.00 Y:-8.00 Z:0.000 E:0.0000
    13:33:47.495 : DebugLevel:6
    13:33:47.496 : SelectExtruder:0
    13:33:47.496 : Begin file list
    13:33:47.497 : End file list
    13:33:47.508 : DebugLevel:6
    13:33:47.508 : SelectExtruder:0
  • I'm not sure what you do wrong, but you are not compiling the new configurations. When you compile without sd card support you MUST have a line
    #define SDSUPPORT 0
    and if that happens the messages like "SD init fail" can not appear, since they are not contained in the compiled binary. That would also explain why inverting sd card detect does not change anything.

    Correct order is reconfigure, download new version and unpack(or copy new configuration.h to old download replacing existing one), open in ide and compile and upload.

    Did you stop all old connections to flash new version? If on windows host or server is connected to printer flashing is not possible and you stay with old version.
Sign In or Register to comment.