Support for MKS v1.5 (HE3D)

Hi,

does Repetier-Host Server support MKS Base v1.5 board?
I can move on all 3 axis, but when I try to home any of them, it just keeps smashing into it until I plug it out.
I've recieved the hardware endstop for the z-axis with my HE3D printer, but I can not confirm it's sending any signal.

Comments

  • Server does support firmwares not boards. For homing we just send G28 to printer firmware. It is the printer firmware that needs to be configured correctly to make homing work. Looks like you did not configure endstops correctly for firmware, so they get ignored.
  • edited January 23
    How to find out whether my firmware is supported? As I mentioned, I can move on all 3 axis.
    I'm a developer, but a complete newb when it comes to 3D printing. Can you point to a basic tutorial on software endstop configuration (as I only have one hardware Z limit switch/endstop)?

    My printer is he3d prusa EI3 single 3D printer kit full metal extruder
  • When you run M115 you see your firmware, most likely marlin:
    https://marlinfw.org/

    That page describes also how to configure it correctly.
    As you can already connect I would say it is supported my us - Marlin is at least along with several other alternatives.
  • Thanks for the tip, however it seems I have the Repetier firmware 0.9.1. I've managed to home the two axis for which I got the limit switches (Y and Z), however homing the X axis seems to end in pain until I hit the emergency button in the UI.
  • Well, same thing as for Marlin. Check with M119 which end stop is configured for x (min or max) and if it is really at that side. Then also check manually if it triggers to high when the sensor is triggered to see if pin is correct and electronic is working as supposed. A typical error is to change homing direction because your x direction is inverted so it homes in correct direction, but then min becomes max so it won't react. So make sure homing direction is -1 for min endstop end if it homes to max position invert x direction instead in configuration.h.
  • edited January 24
    Sorry, I mentioned earlier, it seems I didn't receive the X sensor with the printer package. Should I manually home the X before each print (like a typewriter)?
    Also, what is the correct position of the printhead for starting my first print? I placed a sheet of tinfoil on the bed, to prevent the plastic from sticking - is that ok?
  • plasto said:
    Sorry, I mentioned earlier, it seems I didn't receive the X sensor with the printer package. Should I manually home the X before each print (like a typewriter)?
    Also, what is the correct position of the printhead for starting my first print? I placed a sheet of tinfoil on the bed, to prevent the plastic from sticking - is that ok?

  • Homing without end stop is not possible. Best is to buy an end stop and add it to x end stop pin.
    When you enable/reset printer the position 0,0,0 is assumed. You can also mark current X psoition as 0 using
    G92 X0.
    Homing should then be done with G28 Y0 Z0 instead of G28 which homes all axis. And you need to ensure before print that it does not conatin G28 (default on most slicers) and that X is set correctly.

    tinfoil to prevent it from sticking? Actually you want the filament to stick on bed! The main problem in printing is when it does not stick to bed.
  • On closer inspection I found the missing switch, it just didn't come with the plastic board carrier like the other two.
    Thanks for the foil tip :) , but I have one other issue: the Y axis steps in the direction from rear Y motor towards the user in the front. So, the bed goes all the way to the motor at Y(0). This wouldn't be a problem, except if the print head started oozing - it would go all over the desk, so I guess the Y(0) is not where I want to be at the start of the printing.
Sign In or Register to comment.