How to disable decoupling test?

Having a nightmare of a time with decoupling issues.  Is there a simple way to just deactivate the test?  Already tried setting timing to 0 but that didn't work.  Still tested every 1000 ms or so and returned error.


  • OK...turned off decoupling test in Extruder.cpp.  Now I'm getting crazy temperature fluctuations over a 20°C range.  Is there anyway to go back to the trusty old PID tuning of v0.91?  This new release is a huge PITA.
  • Old PID hasn't change, just use heat manager 2 like before. For 3 you need to adjust dead time to work properly.
  • Will try heat manager 2.  Strange heating behavior only manifests when effector is within 50 cm of the print bed.  Think that's related to the heat manger somehow?
  • Quick question.  I was under the impression PID was heat manager 1 (not 2), with bang bang being 0 and dead time being 3.  Is that correct?  
  • You are right 1 is PID.

    Temperature measurement has no knowledge about z height. z height can only influence physically e.g. if that height changes the temperture readings. Maybe all you have is crosstalk to temp. sensor due to bed heating/position. Does reading change when disabled and < 50mm.
  • Nope.  Reading is steady when not heating.  Just unable to heat up when near the print bed.  Layer fan is disconnected to avoid additional cooling during testing.  So there is really no visible reason it should be faulty when it drops.  Perhaps a bad heating cartridge?  But that doesn't explain why it heats perfectly well above 50 mm.
  • It might be a broken cable and with height it gets better contact or not depending on some bending while it goes up/down. If temps change fast it is the thermistor cable. Would need to see the temperature curve for a better guess.
Sign In or Register to comment.