GT2560 A+ Marlin 2.09 Serial connection

My older GT2560 controller failed, and replaced it with a newer GT2560 A+ model.  V1.02 of the Marlin firmware was on it previously, and Repetier Host V 2.2.2 was fine connecting to serial port.    Repetier host would do a hard reset on serial port but when LCD returned,  would be able to manage the controller and motors and display settings.

New controller board with new marlin 2.0.x firmware installed, but when I hit the connect button, the LCD goes black and Repetier host would never connect.  Tried Cura, and Cura can communicate with new GT2560 A+ and can move motors.  Comm ports are baud rates are same as Cura, so I know the serial communications are good.

Any ideas ?  Thanks in advance


  • First try with ping pong enabled. Normally no problem for marlin, but that is how other hosts communicate. Make sure protocol is ascii. Then you can play with DTR/RTS also the mega boards normally just react on any toggle with reset so it does not rally matter.

    Last thing is to switch into expert mode and enable log and disable all filters and see if you see any communication or hints there what is going on. Normally marlin 2 is no problem.
  • Changed options as recommended, and was able to connect to controller properly again  :o).  Reverted back to see what the issue could have been, and older options worked as well.   Leaving it as you recommended

    I did reflash the 2.x firmware before changing the serial port setting, because Axis were inverted, but I think it was the first flash from 1.x to 2.x that caused it.  Just found it strange that Cura was ok, but not Repetier Host.  Cura 4.x does not cause the hard reset to the controller.
  • Hard reset happens on DTR toggle. If you can prevent it it won't reset. But reset gives you defined start conditions, so is what is preferred.
Sign In or Register to comment.