Unexplained Printer Crash


I am using Repetier-Server Pro 1.1.2.  I use it on a Raspberry Pi with 3 printers connected.  In addition the printers all run the latest version of Repetier-Firmware.

Randomly one or two of the printers will start the printer but right as it begins they enter fail state where the printer head moves all the way to the end of the X axis and jams there.  The extrusion continues and forms a giant blob on the nozzle.  It will run like this the entire print time or until I do a reset.  There is no error in Repetier-Server or on the printer and it shows details as if it were printing normally.

I enabled logging on the printing in Repetier-Server and it shows no errors, it just shows normal Send/Recv.  One thing I noticed is when it fails it does show the layer progress as insanely fast.  It will quickly go from 1 to 50 layers in a minute as if it's somehow in super fast motion.

I tried enabling ping-pong mode on the connection to help but it has not assisted.

Does anybody have any tips.


  • Currently it does not fit together. When print succeeds very fast it is normally when printer is not executing the moves. But then it would not move. So at least some moves seem to get executed here and these might cause the extrusion.

    >Randomly one or two of the printers will start the printer 
    You mean error is randomly or it starts printing also you did nothing?

    Can you provide one of the failed logs? I expect where it gets fast to see an error that caused this. After that all is ok.
  • >Randomly one or two of the printers will start the printer 
    What I mean here is that all the printers are on the same raspberry pi.  The failure is random.  Sometimes 1 or 2 of the printers will present these symptoms while all the others are ok. 

    Here is a printer log from a failed print:

    In this specific print the following happened:
    1. The print was started via Repetier-Server Monitor / Repetier Server
    2. The printer with Repetier-Firmware started to heat normally 
    3. After heating, it starting the normal homing procedure
    4. After that, it immediately went all the way to the X end stop and the motor continue to run despite being at the max X position (it was jammed and pushing to the far end)
    5. It extruded normal amounts of filament but the X was stuck not moving and thus it created a giant blob of filament
    6. The display showed normal output as if the printer thought it was printing
    7. Inside Repetier-Server in the "Move" tab I could see the visualization of that print but it was happening VERY fast as if it was at 1000x speed 
    8. I eventually hit the hard stop on the printer which is the Reset at the end of the log.

  • Ok, no idea why but your printer is in relative positioning mode when it happens. Add a G90 in the start print gcode to ensure absolute positioning. For this reason any move adds xy to pos causing it to stay at maximum position 200/200.

    Only thing I wonder is why I see positions all the time? Have you added a debug option in firmware to always show position?
  • @Repetier ; - No I have not, at least not intentionally. I am not going to pretend I am not special, hah, I may have done something stupid.  But generally I am just using Repetier-Server and stock Repetier-Firmware with changes to make it work for my printer.

    I am going to add "G90 ;Absolute positioning" in my Cura start G-code and re-test, maybe that is the issue.  It's weird it only sometimes happens, but I do suspect some dumb user error on my part.

  • G91 stays active until G90 comes. My guess is that you have it somewhere in the extra gcodes for printer defined maybe. And after that was send and you send next print it fails since it is still in relative mode. But making sur eit is absolute at print start is definitvely a good idea so you do not depend on current setting.
  • Thank you for the awesome support despite this probably not even being a Repetier issue. 

    In my end GCode I had a G91 but I have a G90 after it, not sure why it fails but either way it is a smart idea to have a G90 in my start GCode, I have no Idea why I was missing it, I fixed it in GCode, I bet this will resolve my issue, thanks again.
  • @Repetier - Thank you, this fixed it. 
Sign In or Register to comment.