Please Help! Z Probe always returning the same value regardless of indicator light on probe .

I'm about at my wits end with this one, please help!

I have an auto-leveling probe (the orange tip inductive type) and it can definitely detect when it's near metal (as indicated by the indicator light on top of the probe), however, the firmware is always returning the same value (L). See video here: 

I feel like I've tried just about everything:
- Tried multiple probes, including one from an old printrbot to make sure the its not the hardware that is broken
- Compiling with EEPROM-MODE set to 0 in case configuration overrides in eeprom was changing anything
- Tried the probes with both the 3v on the end-stop connector on the board, and by routing 24V power (from an always-on fan switch while keeping signal in the x-endstop port)
- Tried connecting a normal endstop to the z-min, this does return correct values
- Tried tons of combinations of Z_PROBE_PULLUP, Z_PROBE_ON_HIGH, ENSTOP_PULLUP_X_MIN

My Setup: 
- Makerbase flavor board (24v)
- Running Repetier Firmware v0.92.9
- Using Z-probe in place of the z-min-endstop port
- My configuration.h file can be found here:

Could anyone help me find out what I'm doing wrong? I'm sure there must be something simple i've overlooked


  • Despite using old firmware version if a normal switch works it should normally work as well. But you require a digital switch so you should use a multimeter and measure voltage on the signal pin of the sensor. I know some output analog values so you can measure signal strength, but that won't work. Depending on board we expect 0V or 3.3/5V as signals. Somewhere in between is the cpu switching point, but not sure if it is reliable if you put analog value into that range. Normally you need no pullup for this kind of sensor since electronic should have a defined and not a floating output.
  • Ok getting a little closer now. Now when i run the M119 command. I see Z-Min correctly triggers H or L, but not seeing a z-probe status. Is that normal?
  • You mean your M119 has no part saying "Z-probe state:" ? That would mean you have no z probe defined for firmware and G30 is not available for example.
  • Hey guys, it seems I had a probe working for a while, but it stopped working and now I'm back to square one. It's been a couple of weeks and I haven't been able to get it working. Thinking that it was broken I'm using a new probe. Here are all the details that I can provide.

    Im measuring the output from the signal wire of the probe - It's correctly measuring 0v between the signal wire and ground (on the board) when touching metal and measuring 3.3v when not touching  (I loop this to ground for testing and put the multimeter inbetween). 

    This is all fine so i put the signal wire back to the signal pin on the board. Now this is when I get very strange behavior:

    Upon boot, the board correctly measures 'H' when not touching metal and running m119 command. When touching metal the board reports back 'L', however once i remove the probe the command always returns 'L' regardless of the probe touching metal or not. The only way I can reset this is by either restarting the board, or shorting the ground and signal pin on the port.

    Any insight to why this might be happening?
  • Don't know of this helps, but the probe indicator light seems to always be dimly lit, but its brighter when actually touching metal
  • > however once i remove the probe the command always returns

    what do you mean? I mean removing for z probing makes just no sense so question is what you really did or wanted to say here.

    >Don't know of this helps, but the probe indicator light seems to always be dimly lit, but its brighter when actually touching metal

    Does this also happen when it is in working state? The led might show some metal is close just not enough to trigger or it gets constant signal. Normally I expect on/off or a factor of signal strength. So it might be that during z move you get cross talk preventing signal. You can try putting signal cable loosely for testing so it does not get signals from any other cables.
Sign In or Register to comment.