Toggling ATX-pin


I'm on the newest firmware 0.92.3 and a DUE/RADDS board.

I've connected my RepRap Discount Smartcontroller, and I'm experiencing some issues trying to toggle my ATX-pin through the menu.
The pin doesn’t change state?

I then tried with g-codes M80/M81 from the host-interface, and that works as expected.

How do I proceed the troubleshooting

Best regards


  • Update

    Noticed I could turn on the PSU from LCD-interface, after having it turned off with M81.
    But I cannot turn it off, from the LCD-interface.
  • The lcd menu tries to toggle the ATX signal by reading it's state. Maybe this dos not work for arm based boards. I guess it is the small difference between ARM and AVR technology. Will check that.
  • Thank you very much.

    I will be looking forward to hear more.
  • I could also recreate the problem.

    The reason was quite simple if you know. The LCD toggle always sets ATX to output, but for due this also can change the output value, so we always toggle from high. Latest update fixes the problem.
  • Thank you very much!

    It works now.

Sign In or Register to comment.