Lose all GCODE temperature information

Hey folks,

I've been scratching my head for a few days now. I could be doing something wrong, but this seems to be a bug. 

Version: 2.2.2 
Printer: Geeetech A10M
Self Leveling

Issue. The original GCode that comes with the software looks like this. 

; Default start code
G28 ; Home extruder
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

When I test this, it works fine. Everything is exported to the gcode file as it should be. I didn't copy paste it, because I already lost it. However, when I add this line:

; Default start code
G28 ; Home extruder
G29 ; Level Bed           <<<<<------------------ This line
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

Then everything goes crazy. My actual exported gcode file now looks like this. 

;Generated with Cura_SteamEngine 15.01
; Default start code
G28 ; Home extruder
G1 Z15 F100
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
M190 S50
; Activate all used extruder
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
;Layer count: 87
;LAYER:0
M106 S127
G0 F9000 X86.059 Y88.201 Z2.800
;TYPE:SKIRT
G1 F600 X137.283 Y88.201 E24.32908
G1 X137.283 Y139.425 E48.65816
G1 X114.283 Y139.425 E59.58212

There is no command for extruder temperature, and there is no code for what extruder to use (T0 or T1). And there is nothing I can do about it. I can uninstall and reinstall the program, and it will start working again. But as soon as I add that G29 line just a single time, then everything goes crazy on me and will not output temperature or extruder code. 

Am I missing something simple?

Thanks,
Mac

Comments

  • I copied your block and it works fine.

    In your non working result G29 is also missing, so you either did not safe the new profile or on the right tab you have selected a different profile then the one you edited. Would be the only explaination that makes sense to me knowing that it can work.
  • I was saving all of this code in a different notepad file. I tried removing the G29 line to see if it would go back to normal and resaved it. That's actually what you're seeing. I copy/pasted the wrong one.

    It's a brand new install and only has a single profile, and even after removing the G29 line it doesn't export the hot-end temperature or extruder information. 
     
    I've duplicated the results on a second computer. I'll do it all again this evening with a new install and add some comments in the profile code. I'll try to show it more explicitly, but this does appear to be a legitimate bug. 

    Thank you for the help. Let me know if there is anything else I can try to either confirm the bug, or find what setting is wrong. 

    Mac
  • Did you select Extruder1 in your profile instead of Extruder0?
    That would explain the behaviour as {IF_EXT0}M104 T0 S{TEMP0} generates output only for extruder0.
    For extruder1 ist should look like {IF_EXT1}M104 T1 S{TEMP1}



  • Note that work directory gets not updated or deleted on install/uninstall. So fresh means you delete CuraEngine folder in work directory and restart host. In addition to @RAyWB comment which is definitvely true, do you have defined extruders in host for the printer?

  • RAyWB said:
    Did you select Extruder1 in your profile instead of Extruder0?
    That would explain the behaviour as {IF_EXT0}M104 T0 S{TEMP0} generates output only for extruder0.
    For extruder1 ist should look like {IF_EXT1}M104 T1 S{TEMP1}




    Repetier said:
    Note that work directory gets not updated or deleted on install/uninstall. So fresh means you delete CuraEngine folder in work directory and restart host. In addition to @RAyWB comment which is definitvely true, do you have defined extruders in host for the printer?


    Aha! Now I feel really dumb. I probably should have mentioned this is a dual color printer. I have two extruder motors, but only a single nozzle/mixing extruder. I should have recognized what was happening with the g-code "if" statement, but I'm not savvy enough with it (yet). So yes, that was the main issue. I was slicing on the second extruder (T1) but the code only looked for the first (T0).

    I changed the start g-code to this. I don't know if this is the best way to do it:

    ; Default start code
    G28 ; Home extruder
    G29 ; Level Bed
    G1 Z15 F{Z_TRAVEL_SPEED}
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    {IF_BED}M190 S{BED}
    ; Activate all used extruder
    {IF_EXT0}M104 T0 S{TEMP0}
    {IF_EXT1}M104 T0 S{TEMP1}
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    {IF_EXT0}M109 T0 S{TEMP0}
    {IF_EXT1}M109 T0 S{TEMP1}

    I'm not sure why Repetier doesn't automatically account for this. My printer was set for two extruders and a mixing nozzle. It may be something to account for in a future update. 

    However, I am still confused by something. Just for the fun of it, I loaded a multi color lizard from Thingiverse. I did a couple things just to see how it works out in the g-code. 
    1. First, I set a Skirt to print. In the settings, I say the support extruder is Extruder 2, so the skirt should be printed with T1. 
    2. The body of the lizard is also extruder 2. So it should print with T1.
    3. The eyes are a different color and extruder 1. So it should print with T0. 
    I would attach the g-code for this, but I don't see a way to do it. It starts like this:

    ; Default start code
    G28 ; Home extruder
    G29 ; Level Bed
    G1 Z15 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    M190 S75
    ; Activate all used extruder
    M104 T0 S240
    M104 T0 S240
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    M109 T0 S240
    M109 T0 S240
    ;Layer count: 112
    ;LAYER:0
    M107
    G0 F9000 X64.364 Y69.179 Z0.300
    G0 X64.709 Y68.898
    ;TYPE:SKIRT
    G1 F1800 X65.139 Y68.607 E0.02590
    G1 X65.555 Y68.393 E0.04924
    G1 X66.243 Y68.142 E0.08578
    G1 X66.969 Y68.015 E0.12255

    There is nothing in this code that tells it to start at T1. Shouldn't it start there, since the support material is set for the second extruder? It heats T0, which makes sense as it is a mixing extruder. But I don't see anything to indicate which extruder to start with. In fact, when I search for T1, I don't find it until line 1,085, where it now says ;TYPE:SUPPORT. If support is just starting now, what was it printing before? I haven't actually tried this print, so it probably works fine. But I'm curious how this works. 

    G1 F1800 X34.544 Y151.903 E32.01185
    G1 X19.484 Y151.903 E32.76320
    G1 X19.484 Y136.843 E33.51454
    G1 X34.544 Y136.843 E34.26589
    G92 E0
    G1 F2400 E-16.00000

    T1

    G0 F9000 X31.344 Y140.043
    ;TYPE:SUPPORT
    G1 F2400 E0.00000
    G1 F1800 X31.344 Y148.703 E0.43205
    G1 X22.684 Y148.703 E0.86410

    Thanks to you both for all the help. 
    Mac
  • edited June 18
    EDIT: I figured this one out, so you can ignore this post. If you're curious, Repetier Host ignored that filament profile and defaulted to the default. That one had 50°. I don't know if its a naming issue or something with the config file that I downloaded from Geeetech, but it obviously didn't work. I'll just delete that profile and create my own. I'm still curious about my question above though. 

    SOLVED
    I'm using two computers. The one I posted gcode from above looks like it would have worked successfully, at least for the temperatures. This computer runs my printer, and it looks like here this issue goes over to the heated bed as well. I loaded an xyz test cube to see if I could get a successful print going. This is my start g-code:

    G28 ; Home extruder
    G29 ; Do what I say, when I say it. 
    G1 Z15 F{Z_TRAVEL_SPEED}
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    {IF_BED}M190 S{BED} ; WHY WONT YOU LISTEN TO ME?
    ; Activate all used extruder
    {IF_EXT0}M104 T0 S{TEMP0}
    {IF_EXT1}M104 T0 S{TEMP1}
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    {IF_EXT0}M109 T0 S{TEMP0}
    {IF_EXT1}M109 T0 S{TEMP1}

    Take a look at my filament settings. I snapped an image and have the exported g-code on the side. You'll see I'm using the correct profile names. 
    https://ibb.co/gW1ZcnW

    For some reason, this is exporting with a 50° temp instead of 55°, as in my settings. It looks like that was happening in my first post as well. I just hadn't noticed it. 

    This is my printer extruder setting. So it isn't a maximum temperature issue. 
    https://ibb.co/PtcKMdz

    Weird...




  • quote:
    For some reason, this is exporting with a 50° temp instead of 55°, as in my settings. It looks like that was happening in my first post as well. I just hadn't noticed it.

    do you use same filament settings for both extruders ?
    i´m not that familiar with cura but might be an issue if second filament has a different bed setting
  • Sorry for all the posts. We're probably on very different time zones, so I'm moving through things and discovering different issues/solutions. This will be my last one. 

    Let me first say, I love Repetier Host. This program has always worked great for me. But...it doesn't do well for two extruders and a mixing nozzle. I sliced the test cube on extruder 2 (T1) and printed. It didn't work. It printed with the first extruder. Not surprising, because there is nothing in the g-code that tells my printer to use the second extruder.

    There is a workaround, I just had to add T1 into the start g-code, but then I have to remember to use the right profile setting. This seems like another upgrade that Repetier could make. It is just one line based on what extruder you choose for your part. 

    ;Generated with Cura_SteamEngine 15.01
    G28 ; Home extruder
    G29 ; Do what I say, when I say it.
    G1 Z15 F100
    M107 ; Turn off fan
    G90 ; Absolute positioning
    M82 ; Extruder in absolute mode
    M190 S57 ; Thank you for listening
    ; Activate all used extruder
    M104 T0 S210
    G92 E0 ; Reset extruder position
    ; Wait for all used extruders to reach temperature
    M109 T0 S210

    T1     ;  Second extruder, coming right up.   (From start g-code   <<<---------------------------)
    ;Layer count: 100
    ;LAYER:0
    M107
    G0 F6600 X75.372 Y75.372 Z0.240
    ;TYPE:SKIRT
    G1 F1800 X144.628 Y75.372 E2.89545
    G1 X144.628 Y144.628 E5.79091
    G1 X75.372 Y144.628 E8.68636
    G1 X75.372 Y75.372 E11.58182
  • RAyWB said:
    quote:
    For some reason, this is exporting with a 50° temp instead of 55°, as in my settings. It looks like that was happening in my first post as well. I just hadn't noticed it.

    do you use same filament settings for both extruders ?
    i´m not that familiar with cura but might be an issue if second filament has a different bed setting
    I edited the post above. I actually found the solution to that one. It was ignoring the profile setting, which I had downloaded from the Geeetech website. It defaulted back to default. 
  • Just some comments: CuraEngine with out rype of config is not developed any more and at the time it stopped it was quite picky about 2 extruder support, e.g. you need to use extruder 1 on an object if you want to use extruder 2 as well. Also beside the start/end code all comes from curaengine and I can not change the behaviour. That includes start extruder I guess.

    You are not the first mentioning the settings are not being used, but I can never replay the problem. So I still think these users do something wrong and I can not say what. Importent fact is left configs must be saved so the changes are used. Also selecting them on the left side does not use them - you need to select the profile on the right side in the dropdown box. Actually normally left side is never opened once you found your settings.
Sign In or Register to comment.