help with setting endstops

i have built a custom 3d printer with ramps and repetier firmware, the problem is i have three endstops at the end of each of the axis x y and z however the position of these endstops is not same as the minimum position of my bed/printable area, so what this means is my bed is smaller than the distance that can be travelled by the printer, how do i set this in the firmware such that it still homes to these endstops but knows that the bed is further away from it , thanks 


  • That depends on what you want. If you want the extruder always to stop over the bed you just adjust
    // When you have several endstops in one circuit you need to disable it after homing by moving a
    // small amount back. This is also the case with H-belt systems.
    #define ENDSTOP_X_BACK_ON_HOME 5.0
    #define ENDSTOP_Y_BACK_ON_HOME 5.0

    so it moves extra mm after hitting endstop and assumes this as xmin/ymin 0 normally.

    The other solution is to change xmin/ymin
    // Coordinates for the minimum axis. Can also be negative if you want to have the bed start at 0 and the printer can go to the left side
    // of the bed. Maximum coordinate is given by adding the above X_MAX_LENGTH values.
    #define X_MIN_POS 0
    #define Y_MIN_POS 0

    If these are negative it means 0 is more to the right and you can tell host/slicer that bed starts at 0 but you can move into negative coordinates as well.
  • thank you, could you also tell me where i can get the latest repetier firmware without using the configurator tool, the one which has all the comments in the code 
Sign In or Register to comment.