Exruder motor just stops

Hello everybody,

my extruder motor just stops turning after a 2-3 minutes. The printer doesn't output any error message on the terminal. The stepstick and motor stay cool (25 - 30 degrees I'd say). The stepsticks are cooled with a fan btw. When I reset the printer, the extruder motor immediately works again.

I already tried replacing the motor cables with new ones twice. I also replaced the extruder motor and tried a different TMC2208 of which I am sure that it works.

I even switched from Arduino Mega + Ramps to Arduino Due + RADDS 1.4. This did also not help (but I am staying with Due + RADDS now).

I don't know what else to try. With no error message, you'd think it can't be something in the firmware. But maybe someone knows something I don't.

Here is a pastebin of my configuration.h:


  • My problem is (I think) that repetier has support for some of the TMC stepper drivers, but I can't find any guides on how to use the TMC2208s in repetier.
  • After 2-3 minutes is strange. That means normally configuration is ok. Do you have a host software connected to see firmware output? It might have gone into dry run mode because of a temperature error. After that time it might be the decouple test, but it would write into log that it was activated. M111 S6 would disable dry run, M301 S1 disables preventing cold extrusions so it would also move when temperature is too low (for testing only). M999 recovers from decouple error I think until it happens again.

    TMC2208 support is not in V1, only in V2 firmware. But problem is I think that it is the serial version and you need a serial per chip. But since your drivers work at start I do not really think that is the reason.
Sign In or Register to comment.