Repetier-Host 2.2.0 verschluckt Layer bei Prusa-Slicer

Ich hoffe das dies nur die Anzeige / Vorschau betrifft. Aber mir ist etwas aufgefallen. Ich hatte heute morgen mit Repetier-Host ein STL gesliced und es auf den Server geladen. Der Druck läuft gerade. Ich verwende oft die Vorschau im Repetier-Host um sozusagen, den nächsten Meilenstein beim Drucken zu erfahren. Doch der kam nicht bei Layer 67. Selbst bei Layer 70 kam er nicht. Also prüfte ich mal was passiert. Und beim Slicen in Repetier-Host wird das Objekt quasi in den Boden versenkt.

Vor dem Slicen
https://ibb.co/48jcmXS 

Nach dem Slicen
https://ibb.co/hZv0H9q

Am Pusa-Slicer liegt es nicht, denn ich verwende schon lange den 2.3.x im Repetier-Host. Also den Vorgang auch beim Prusa direkt durchgeführt.

Vor dem Slicen
https://ibb.co/87MJFSB

Nach dem Slicen
https://ibb.co/4tr4ZXg

Vielleicht nicht schlimm... ;-)

Comments

  • edited May 10
    Achso, was ich drucke natürlich. https://www.thingiverse.com/thing:3927885

    Die Datei Fan_Housing.stl

    Es sind genau 4 Layer. ;-) //Edit da liegt irgendwo ein Rechenfehler vor, weil ein 11mm hohes Objekt nur noch 53 statt 55 Layer hat.
  • Hab versucht es bei mir zu sehen aber kein Unterschied erkennbar. Dirket im Prusa und über host war layer 24 der gleiche bei mir. Aber du bist der zweite der das selber hat. Auch wenn ich es nur schwer sehen kann auf den Bildern bin ich daher geneigt das zu glauben. Frage ist nur welche Einstellung führt zu dem Problem. Ich hab das Objekt 180° um x Achse gedreht und mit 0.15mm Layerhöhe gesliced.

    Wenn du die verwendete Drucker und Druck Einstellung noch posten kannst würde ich es damit noch mal versuchen. Hast du sonst noch was einsgestellt? Ich hab oOverride und variable Layerhöge deaktiviert.
  • So, ich habe mal ein File mit dem Prusa-Slicer direkt exportiert und auf Github geladen. Da kannst du die .gcode und die Datei der Settings (als 7z) für den Prusa herunterladen. Anders kann ich mir jetzt auch nicht vorstellen, wie ich dir sonst die Einstellungen posten könnte. 

    https://github.com/Siox0911/Repetier-Host-Files
  • edited May 10
    Zusätzlich die STL Datei und so weiter. Bin aktuell zur 2.1.6 zurück gesprungen. Auch wenn da jetzt (erst nach Update und zurück) der Slicer-Manager abraucht.  :)
  • Ok, ich sehe du hast eine "alte" 2.2.0 erwischt. Die gab es ganz kurz bis ich merkte das PrusaSlicer 2.3.1 raus ist. Kannst du die noch mal neu runterladen und testen ob das Problem da weg ist, da meine Tests mit der version erfolgt sind. Möglicherweise ist es da schon behoben. Es gab da ja in der tat ein Problem mit transformation die durch das Drehen vermutlich zum tragen kommt.
  • Nein ist nicht weg. Und wie schon gesagt. Der Prusa Slicer ist nicht das Problem. Ich kann es dort reinziehen und slicen. Wenn ich dann den G-Code in den Host lade, ist auch alles gut. Nur wenn ich im Host slice dann ist das so. Aber nur in 2.2.0 und nicht in 2.1.6.
  • Also ich habe jetzt mal mit beiden Versionen im Host gesliced. Diese beiden Dateien unterziehe ich gerade einem Vergleich. Habe die Dateien auch ins Git geladen. Nachdem ich nur die ersten Layer gelassen habe, habe ich einen anderen Verdacht. Die beiden gesliced Dateien unterscheiden sich dramatisch von einander. Wie übergibst du denn die STL an den Slicer. Ich sehe zwar mit welchem Commando du das antriggerst aber nicht wie die STL übergeben wird.
  • Habe mal die erzeugten AMF Dateien zur Brust genommen. Vielleicht wirst du schlau, ich leider nicht so sehr. Außer dass die sich auch dramatisch unterscheiden. 

    https://ibb.co/F5Q9Mc7
  • Vermutlich liegt das Problem auch in der AMF Datei. Von deinen g-codes weiß ich das 4 Layer fehlen. Wenn ich meinen ansehe ist der kleinste Z wert -29.8
            <vertex>
              <coordinates>
                <x>10.666174</x>
                <y>-45.773403</y>
                <z>-29.8</z>
              </coordinates>
            </vertex>

    Was aber ok ist da ich ganz am Ende der Datei:
    <constellation id="1">
        <instance objectid="0">
          <deltax>120</deltax>
          <deltay>120</deltay>
          <deltaz>29.7999997138977</deltaz>
          <rx>0</rx>
          <ry>0</ry>
          <rz>0</rz>
          <scalex>1</scalex>
          <scaley>1</scaley>
          <scalez>1</scalez>
          <mirrorx>1</mirrorx>
          <mirrory>1</mirrory>
          <mirrorz>1</mirrorz>
          <printable>1</printable>
        </instance>
      </constellation>

    Alles 29.8mm nach oben schiebe. Das AMF in 2.2.0 hat sich in der Tat geändert und vermutlich ist da auch das Problem. Nur weiß ich nciht wie du es schaffst ein amf zu erzeugen das zu tief liegt. Ich seh ja am Bild das du das Objekt 180 grad gedreht hast. Wa sich mache ist rotieren anklicken und dann entweder bei X oder Y achse 2 mal +90 klicken oder 180 eintragen. Dann slice ich und es klappt.
    Welche Schritte machst du nach dem stl import? Möglicherweise machst du einen anders wodurch Z falsch korrigiert wird.

    Aber nur zur sicherheit kannst du das composition.amf mit dem Fehler auch auf github packen. Dan kann ich zumindest die theorie untersuchen.

  • Richtig, per Drag and Drop reinziehen und Rotation anklicken und 2x auf X +90.

    Und meine Druckerform: https://ibb.co/W5fCJSc


  • Bitte kannst du das generierte composition.amf mit dem Fehler auch posten. Ich mache genau das was du beschrieben hast und es klappt. Die einzige Möglichkeit das zu provozieren ist wenn ich Z des objekts von 10 auf 9.2 reduziere. Aber wenn ich dann slicer meldet der Host das Problem und fragt ob ich es wirklich will. Das hat er vermutlich nicht gemacht bei dir, sonst hättest du es ja erwähnt. Also muss der Defekt vermutlich in der Datei liegen ohne das der Host es sieht. Also beim umwandeln passieren. Aber um das zu bestätigen brauch ich die fehlerhafte composition.amf da ich sie leider nicht fehlerhaft erzeugen kann, was an sich schon ein Rätsel ist.

    Passiert der Fehler auch bei anderen Objekten insbesondere wenn sie nicht gedreht werden?
  • Also ich wollte den XYZ CalibrationCube vorführen, aber der lief korrekt. Da ich aber aktuell ein Projekt drucke, hatte ich nicht viel Spiel für Tests. 

    Die Frage ist halt, was macht 2.2.0 anders als die 2.16. Weil, die vorherige (2.1.6) funktioniert wieder, wenn man diese über die 2.2.0 installiert. Welche Abhängigkeiten wurden in der 2.2.0 eingefügt, die vielleicht genutzt aber nicht unbedingt mit installiert werden, wenn diese bereits vorhanden sind? Siehe Python usw.
  • Danke für die amf-Datei. Sie hat das Problem gezeigt:

     <constellation id="1">
        <instance objectid="0">
          <deltax>110</deltax>
          <deltay>120</deltay>
          <deltaz>29,7999997138977</deltaz>
          <rx>0</rx>

    Du siehst er hat 29.8 als 29,8 also mit komma geschrieben. Muss aber . nutzen sonst nimmt Prusa nur 29 und damit ist es 0.8 tiefer und 8 layer fehlen. Ich hab bei mir trotz Deutsch . als dezimaltrennzeichen eingestellt, daher passiert es bei mir nicht. Werd das für 2.2.1 fixen und zügig das update raus geben.
  •  :p  <3 :D 
    Geil 
  • edited May 15
    Gerade installiert. Und es funktioniert... Vielen, vielen Dank.  B) 

    Repo auf Github gelöscht.
Sign In or Register to comment.