Missing Layers and wrong Z height on Slic3r 2.+

Hi I noticed as I tried to print thin layers that somehow the transfer from Repetier host and slic3r caused missing 3 layers...

I tried a lot, and the problem lies n the amf file loading.

I loaded the "composition.amf" in slic3r and all is fine
I loaded the composition.amf in RH and saved it as stl file then run slic3r with the same settings from the command line but with the stl instead of the amf file also fine

This happens also only with thin objects at the build plate ( 20x20mm cube is fine) 

Problem exists not on Slic3r 1.3 versions only on 2+

Here are all the files in question

A easy fix would be to use stl as transfer format again ?



  • How do you know 3 layer are missing? Because host said it has 3 layer less? Host does not use layers from slicer but has own logic, so it can differ. But gcode should be identical and have same content.

    Using STL is no option - it can not contain the extra data we transfer in amf. And it would be identical as we also recreate that from our dataset, so if our rotation causes the layer difference when you need to rotate it would also be in stl.
  • well something is wrong is I get vastly different results from using the stl vs the amf.
    the model has a 1.5mm thick bottom part, I'm not talking about some small height offset. 

    from the stl I get about 5 layers with 0.3mm layer height ( first layer is 0.35mm)
    from the amf I get only 2 layers also the z height of the layers add up to way less than 1.5mm 

    If I open slic3r and load the stl or the amf directly I get 5 layers. 

  • Yes, sound wrong. Will have a look at your sample files and check if I can reproduce.
  • > Problem exists not on Slic3r 1.3 versions only on 2+
    You mean Prusa Slicer? Whcih version do you see in gcode when you check gcode? Is it 2.3.0 or 2.3.1? 

    If you have 2.3.0 please redownload so it becomes 2.3.1. 

    I could not download your samples. Had another user where it was 2.3.0 with same problem, but coul dnot reproduce with 2.3.1 bundled 2.2.0. 
  • I could not download your samples. Permission denied.
  • Hi, I'm sorry google moves from easy to use to something else
    I think now it works 

  • Ok found the problem. Happens if your windows has , as default fraction separator, e.g. windows if you have not changed it. That causes models eventually to not move the last fraction only integer part and then some layers might miss. Will be fixed for 2.2.1 - until then select region "Schweiz" to get . as number formatter or change it in 
    Systemsteuerung\Zeit und Region -> Datums, Uhrzeit- und Zahlenformate ändern -> Weitere Einstellungen.
Sign In or Register to comment.