DEV2: Clean installation not compiling

edited March 12 in General
Hi,
I made a break working on my printer because of my job.
I want to use the latest version of DEV2 and wanted to be able to use the git software, to always have the latest version. I tried it synchronizing it in Visual Studio, but I failed. I failed for a couple of ways and installations.

Latest thing I tried was to download a zip-file of DEV2 and extract it to a folder. Than I opened the folder in Visual Studio. It does not show the option to compile but gives this message:
#include-Fehler erkannt. Aktualisieren Sie Ihren includePath. Wellenlinien sind für diese Übersetzungseinheit (C:\Daten\3D\Repetier-Firmware-dev2\src\Repetier\src\Configuration.cpp) deaktiviert.

and

Die Datei "Quelle" kann nicht geöffnet werden: "math.h". (dependency of "Repetier.h")

I would have expected that a clean download is directly compilable. What am I doing wrong? 

best regards
karl.ranseier

edit: I am working with win10


Comments

  • First do not use zip file. You need to install it with git clone so you can pull new updates any time. Then switch to the dev2 branch to get the dev2 sources and not V1 stable.

    Not sure if this works in Visual Studio - it was developed with Visual Studio Code and also requires the platformio plugin so all includes and packages get installed automatically on compile including required cross compiler. But you need to compile with platformio not with studio directly. Maybe that plugin also works in visual studio can't say. But I at least have math.h which is a standard c library available on all C/C++ installations since 20 years.
  • Ok, sorry for the missing details. I am using visual studio code with platformio as I used before to compile all the other version. At that time I always used the zip-file. Exactly beacause of this uncomfortable behaviour I tried the git included in visual studio code. Without success. Than I tried the git desktp app, without success. Than I switched back to the zip-file, opening the folder in visual studio code and than got that problem, that it does not compile.
  • Did you configure platformio.ini to your board and install the framework? Also I think it should install framework automatically it might be a reason that math.h misses. After all it is part of the cross compiler so that is where it would come from. Which architecutre/board are you using?
  • edited March 13
    guess you opened folder Repetier-Firmware-dev2\src\Repetier\src

     then i also get the errors.

    if you open folder Repetier it should work.





  • RAyWG: Thanks! I opened Repetier-Firmware-dev2\src , now it works. Thanks! One of those situation you know "the solution is easy, but I cannot see it"
    Now I will go back to try to make the gut extension work fine for me.
Sign In or Register to comment.