Serial com error:System.IO.Ports.SerialErrorReceivedEventArgs

Using Windows 7 Professional Service Pack 1
Repetier Host version 1.5.5
Check for Updates does not give me anything new

Printer: Colido DIY, no SD card

When I very first set it up in December, I was able to get two prints out of it (the kitty that came on the flash drive that came with the printer), but since then this is all I get:
I have tried restarting my computer (usually fixes most problems), restarting the printer, restarting the Repetier Host, Changing the cord that connects the printer to the computer, uninstalling and reinstalling the repetier host (hoping maybe the driver was the issue?). I tried plugging it into other USB ports, but COM3 is the only one it will connect to.

I think the problem started when I tried to print something else that I had made. I had it slice the .stl file to get the gcode and sent it to the printer and have gotten nothing since.

When I looked at "Printer Information" in the menu, it says machine type Unknown.

In Manual Control, you can see the commands being sent. There are 6 commands waiting when it first starts up and they count down to 1. There is one more command waiting at the end, but the next day that command is still waiting.

16:21:15.937 : OpenGL version:4.0.0 - Build 10.18.10.3412
16:21:15.939 : OpenGL extensions:GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_blend_color GL_EXT_abgr GL_EXT_texture3D GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_SGIS_texture_edge_clamp GL_SGIS_generate_mipmap GL_EXT_draw_range_elements GL_SGIS_texture_lod GL_EXT_rescale_normal GL_EXT_packed_pixels GL_EXT_texture_edge_clamp GL_EXT_separate_specular_color GL_ARB_multitexture GL_ARB_map_buffer_alignment GL_ARB_conservative_depth GL_EXT_texture_env_combine GL_EXT_bgra GL_EXT_blend_func_separate GL_EXT_secondary_color GL_EXT_fog_coord GL_EXT_texture_env_add GL_ARB_texture_cube_map GL_ARB_transpose_matrix GL_ARB_internalformat_query GL_ARB_internalformat_query2 GL_ARB_texture_env_add GL_IBM_texture_mirrored_repeat GL_EXT_multi_draw_arrays GL_SUN_multi_draw_arrays GL_NV_blend_square GL_ARB_texture_compression GL_3DFX_texture_compression_FXT1 GL_EXT_texture_filter_anisotropic GL_ARB_texture_border_clamp GL_ARB_point_parameters GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_env_crossbar GL_EXT_texture_compression_s3tc GL_ARB_shadow GL_ARB_window_pos GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_ARB_vertex_program GL_EXT_texture_rectangle GL_ARB_fragment_program GL_EXT_stencil_two_side GL_ATI_separate_stencil GL_ARB_vertex_buffer_object GL_EXT_texture_lod_bias GL_ARB_occlusion_query GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_non_power_of_two GL_ARB_vertex_shader GL_NV_texgen_reflection GL_ARB_point_sprite GL_ARB_fragment_program_shadow GL_EXT_blend_equation_separate GL_ARB_depth_texture GL_ARB_texture_rectangle GL_ARB_draw_buffers GL_ARB_color_buffer_float GL_ARB_half_float_pixel GL_ARB_texture_float GL_ARB_pixel_buffer_object GL_EXT_framebuffer_object GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_occlusion_query2 GL_EXT_draw_buffers2 GL_WIN_swap_hint GL_EXT_texture_sRGB GL_ARB_multisample GL_EXT_packed_float GL_EXT_texture_shared_exponent GL_ARB_texture_rg GL_ARB_texture_compression_rgtc GL_NV_conditional_render GL_ARB_texture_swizzle GL_EXT_texture_swizzle GL_ARB_texture_gather GL_ARB_sync GL_ARB_framebuffer_sRGB GL_EXT_packed_depth_stencil GL_ARB_depth_buffer_float GL_EXT_transform_feedback GL_ARB_transform_feedback2 GL_ARB_draw_indirect GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_ARB_framebuffer_object GL_EXT_texture_array GL_EXT_texture_integer GL_ARB_map_buffer_range GL_ARB_texture_buffer_range GL_EXT_texture_snorm GL_ARB_blend_func_extended GL_INTEL_performance_queries GL_ARB_copy_buffer GL_ARB_sampler_objects GL_NV_primitive_restart GL_ARB_seamless_cube_map GL_ARB_uniform_buffer_object GL_ARB_depth_clamp GL_ARB_vertex_array_bgra GL_ARB_shader_bit_encoding GL_ARB_draw_buffers_blend GL_ARB_geometry_shader4 GL_EXT_geometry_shader4 GL_ARB_texture_query_lod GL_ARB_explicit_attrib_location GL_ARB_draw_elements_base_vertex GL_ARB_instanced_arrays GL_ARB_base_instance GL_ARB_fragment_coord_conventions GL_EXT_gpu_program_parameters GL_ARB_texture_buffer_object_rgb32 GL_ARB_compatibility GL_ARB_texture_rgb10_a2ui GL_ARB_texture_multisample GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_timer_query GL_ARB_tessellation_shader GL_ARB_vertex_array_object GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_texture_cube_map_array GL_EXT_gpu_shader4 GL_ARB_gpu_shader5 GL_ARB_gpu_shader_fp64 GL_ARB_shader_subroutine GL_ARB_transform_feedback3 GL_ARB_get_program_binary GL_ARB_separate_shader_objects GL_ARB_shader_precision GL_ARB_vertex_attrib_64bit GL_ARB_viewport_array GL_ARB_transform_feedback_instanced GL_ARB_compressed_texture_pixel_storage GL_ARB_shader_atomic_counters GL_ARB_shading_language_packing GL_ARB_shading_language_420pack GL_ARB_texture_storage GL_EXT_texture_storage GL_ARB_vertex_attrib_binding GL_ARB_multi_draw_indirect GL_ARB_program_interface_query GL_ARB_debug_output GL_KHR_debug GL_ARB_arrays_of_arrays GL_INTEL_map_texture GL_ARB_texture_compression_bptc GL_ARB_ES2_compatibility GL_ARB_robustness GL_EXT_texture_sRGB_decode 
16:21:15.939 : OpenGL renderer:Intel(R) HD Graphics 4000
16:21:15.939 : Using fast VBOs for rendering is possible

I think the problem is here, but I don't know how to fix it

16:21:36.257 : Serial com error:System.IO.Ports.SerialErrorReceivedEventArgs
16:21:40.868 : No start signal detected - forcing start
16:21:40.925 : N1 M110 *2
16:22:20.978 : Communication timeout - reset send buffer block
16:22:20.978 : N2 M115 *4
16:23:01.054 : Communication timeout - reset send buffer block
16:23:01.054 : N3 M105 *4

Please respond in simple language. I can run a computer, but am not an expert at all.

Thank you,
Jo MacDonald

Comments

  • As I see you are connected to some serial but do not get responses that can be understood.
    Most likely you have set the wrong baud rate in printer settings. Try different ones like 115200 and 250000 which are the most common. Also make sure the COMx port is correct. If you remove the printer from pc th eport name should disappear in the dropdown list where you set it in printer settings.
  • I had it at 115200 and 250000 doesn't connect at all.
  • Com port is correct, it is the only one that will even attempt to connect to the printer
  • Does the com port disappear if you unplug the printer? Otherwise you might be missing the serial driver for the printer and it never appeared.
  • edited January 28
    Yes, under printer settings, when I unplug the printer, COM3 disappears. The only thing left is Auto
  • Does the printer lcd still work? Doe sit have one? Com port is right but if firmware is not running you also get no communication so next would be to test if firmware is still working.
  • edited January 28
    The printer does not have an LCD. So the drivers are ok?
  • Yes, since the com port disappeared it means windows drivers are working and they are responding on printer. But these printers normally have an extra chip for communication so that does not mean the firmware is running. And without an lcd it is also hard to test if it does and I don't know/have that printer so can't say anything about how it should behave. 

    Also the host version is old it is preconfigured for the printer and should work with the initial settings which I hope you have still set. I mean after all you did get 2 prints from this so at that time they worked so they must have been correct.

    I see no more easy help here. If you have the firmware binary you could try to flash it again. This requires the processor to respond  so would be a test if the board is still alive. Check printer homepage for this. And maybe they can help more knowing their printers better then me.
Sign In or Register to comment.