bed leveling routine problem


i have a problem with the bed leveling and i think it's because of a problem with the bed leveling routine

i set the three z probe points to probe the point near the A tower after that the point near the B tower and then the point near the C tower and i send g32 s2 

the probe tried to move to the point near the A tower and then moved down to measure all points 
the result was that the firmware thinks that the a slider must be lower and after homing it always makes it lower than the others if the auto bed leveling is turned on 

i tried to change the probing points to make them B then A then C the same problem moved to the B slider and that means that the problem is with the first point always

i think that the problem with the bed leveling itself because the carriage moves near the tower before moving down and that limits the movement of the slider of the tower 

i tried to send g32 after moving the carriage down so all sliders can move up and down freely and every thing went ok 

so please Repetier tell me what you think 


  • I think you are using 0.91 and should upgrade to 0.92.3. There I have no problems with auto leveling my delta and the routine has changed to prevent some problems with starting too high and other fixes.

    Apart from this I'm not truly sure I understand the problem from the description, but sounded like I started to high so slider could not do the move they needed causing a error in the result. New routine now goes first down and then moves to the points so it prevents this problem.
  • thank you for your respond 

    you are true i was using v 0.91 but today i tried v0.92.3 (downloaded it from the configuration tool)

    bed leveling fixed  but can i download the latest version without using the configuration tool ??

    and an other question , while compiling the firmware a warning appears :

    ""Global variables use 6,569 bytes (80%) of dynamic memory, leaving 1,623 bytes for local variables. Maximum is 8,192 bytes.
    Low memory available, stability problems may occur.""

    that warning appears if i activate sd support is that normal ??
  • 1. on github work092 branch is 0.92.3 version
    2. Warning is normal. The ide does not know how much free memory we need. We need around 1000 bytes to be safe.
Sign In or Register to comment.