Seit Update 1.0.2 - Communication Timeout

Hallo zusammen,

seit dem letzten Update habe ich Probleme mit meinem 2. Sidewinder X1, das der immer die Kommunikation verliert. Vor dem Update lief alles stabil. Die Firmware wurde nicht geändert und ist original ab Werk. Nebenbei läuft noch ein Ender 5 Plus, auch mit originaler Firmware, und ein zusätzlicher Sidewinder X1 mit Marlin 1.1.9. Auf diesen Druckern besteht das Problem bisher nicht. 
Der Fehler tritt auch unspezifisch auf. Also mal nach einer Stunde oder, wie jetzt gerade, nach 16 Stunden Druckzeit. 
Gibt es dafür ggf. eine Lösung?

Recv:10:28:33.065:  T:196.96 /197.00 B:60.05 /60.00 @:37 B@:0
Recv:10:28:33.317: ok
Send:10:28:33.317: N961296 G0 X98.6 Y133.307
Recv:10:28:33.331: ok
Send:10:28:33.331: N961297 G0 X94.444 Y134.091
Recv:10:28:33.532: ok
Send:10:28:33.533: N961298 G0 X94.271 Y134.954
Recv:10:28:33.912: ok
Send:10:28:33.912: N961299 M204 S700
Recv:10:28:33.917: ok
Send:10:28:33.918: N961300 G1 F2400 E1321.88134
Recv:10:28:34.064:  T:196.88 /197.00 B:60.02 /60.00 @:38 B@:4
Recv:10:28:34.116: ok
Recv:10:28:34.116: ok
Send:10:28:34.116: N961301 G1 F1500 X94.058 Y135.219 E1321.89231
Recv:10:28:34.318: ok
Send:10:28:34.318: N961302 G1 X93.838 Y135.233 E1321.89942
Recv:10:28:34.380: ok
Send:10:28:34.380: N961303 G1 X94.251 Y134.954 E1321.9155
Recv:10:28:34.446: ok
Send:10:28:34.446: N961304 G1 X94.271 Y134.954 E1321.91615
Recv:10:28:34.610: ok
Send:10:28:34.610: N961305 M204 S500
Send:10:28:34.610: N961306 G1 F2400 E1321.01615
Recv:10:28:34.758: ok
Recv:10:28:34.758: ok
Send:10:28:34.758: N961307 G0 F7500 X93.779 Y134.229
Send:10:28:34.759: N961308 G0 X90.968 Y136.142
Recv:10:28:34.762: ok
Send:10:28:34.762: N961309 G0 X90.934 Y136.999
Recv:10:28:34.837: ok
Send:10:28:34.837: N961310 M204 S700
Recv:10:28:34.916: ok
Send:10:28:34.916: N961311 G1 F2400 E1321.91615
Recv:10:28:35.064:  T:196.93 /197.00 B:60.10 /60.00 @:37 B@:0
Recv:10:28:35.100: ok
Recv:10:28:35.100: ok
Send:10:28:35.100: N961312 G1 F1500 X91.368 Y137.864 E1321.94737
Recv:10:28:35.535: ok
Send:10:28:35.535: N961313 G1 X91.481 Y137.946 E1321.95187
Recv:10:28:35.583: ok
Send:10:28:35.583: N961314 G1 X91.407 Y138.126 E1321.95815
Recv:10:28:35.616: ok
Send:10:28:35.616: N961315 G1 X91.273 Y138.14 E1321.9625
Recv:10:28:35.738: ok
Send:10:28:35.739: N961316 G1 X91.126 Y137.689 E1321.9778
Recv:10:28:35.748: ok
Send:10:28:35.748: N961317 G1 X90.52 Y137.247 E1322.002
Recv:10:28:35.866: ok
Send:10:28:35.866: N961318 G1 X90.149 Y137.251 E1322.01397
Recv:10:28:35.925: ok
Send:10:28:35.925: N961319 G1 X90.496 Y136.999 E1322.02781
Recv:10:28:35.947: ok
Send:10:28:35.948: N961320 G1 X90.934 Y136.999 E1322.04194
Recv:10:28:35.975: ok
Send:10:28:35.976: N961321 M204 S500
Send:10:28:35.976: N961322 G1 F2400 E1321.14194
Recv:10:28:35.993: ok
Recv:10:28:35.993: ok
Send:10:28:35.993: N961323 G0 F7500 X90.968 Y136.142
Send:10:28:35.994: N961324 G0 X125.161 Y139.052
Recv:10:28:36.027: ok
Send:10:28:36.028: M117 ETE 27:06:09
Recv:10:28:36.067:  T:197.19 /197.00 B:60.05 /60.00 @:33 B@:1
Recv:10:28:36.089: ok
Send:10:28:36.089: N961325 G0 X125.589 Y139.31
Recv:10:28:36.143: ok
Recv:10:28:36.143: ok
Send:10:28:36.144: N961326 G0 X125.347 Y139.067
Send:10:28:36.145: N961327 G0 X148.021 Y140.997
Recv:10:28:36.274: ok
Send:10:28:36.274: N961328 G0 X152.07 Y137.957
Recv:10:28:36.334: ok
Send:10:28:36.335: N961329 G0 X152.444 Y137.958
Recv:10:28:36.357: ok
Send:10:28:36.357: N961330 G0 X154.717 Y137.372
Recv:10:28:36.411: ok
Send:10:28:36.411: N961331 G0 X153.636 Y141.475
Recv:10:28:36.421: ok
Send:10:28:36.421: N961332 G0 X182.583 Y143.94
Recv:10:28:36.439: ok
Send:10:28:36.439: N961333 G0 X183.393 Y143.725
Recv:10:28:36.451: ok
Send:10:28:36.451: N961334 M204 S700
Recv:10:28:36.482: ok
Send:10:28:36.482: N961335 G1 F2400 E1322.04194
Recv:10:28:36.520: ok
Recv:10:28:36.520: ok
Send:10:28:36.520: N961336 G1 F1500 X183.445 Y143.179 E1322.05963
Recv:10:28:36.543: ok
Send:10:28:36.543: N961337 G1 X185.876 Y135.706 E1322.31317
Recv:10:28:36.572: ok
Send:10:28:36.572: N961338 G1 X193.076 Y130.431 E1322.60113
Recv:10:28:36.602: ok
Send:10:28:36.602: N961339 G1 X201.727 Y130.431 E1322.88023
Recv:10:28:36.625: ok
Send:10:28:36.626: N961340 G1 X208.73 Y135.529 E1323.15969
Recv:10:28:36.682: ok
Send:10:28:36.682: N961341 G1 X211.404 Y143.747 E1323.4385
Recv:10:28:37.065:  T:196.96 /197.00 B:60.06 /60.00 @:36 B@:0
Recv:10:28:37.157: ok
Send:10:28:37.157: N961342 G1 X208.73 Y151.965 E1323.71731
Recv:10:28:37.186: ok
Send:10:28:37.186: N961343 G1 X201.727 Y157.063 E1323.99677
Recv:10:28:37.213: ok
Send:10:28:37.214: N961344 G1 X193.077 Y157.063 E1324.27584
Recv:10:28:37.590: ok
Send:10:28:37.590: N961345 G1 X186.074 Y151.965 E1324.5553
Recv:10:28:37.749: ok
Send:10:28:37.750: N961346 G1 X183.393 Y143.725 E1324.83486
Recv:10:28:37.772: ok
Send:10:28:37.772: N961347 M204 S500
Send:10:28:37.772: N961348 G0 F7500 X184 Y142.377
Recv:10:28:37.860: ok
Recv:10:28:37.860: ok
Send:10:28:37.861: N961349 M204 S700
Recv:10:28:38.014: ok
Recv:10:28:38.015: ok
Send:10:28:38.015: N961350 G1 F1500 X183.721 Y143.235 E1324.86397
Send:10:28:38.015: N961351 G1 X183.678 Y143.695 E1324.87887
Recv:10:28:38.064:  T:196.93 /197.00 B:60.07 /60.00 @:37 B@:0
Recv:10:28:38.433: ok
Send:10:28:38.434: N961352 G1 X184 Y144.684 E1324.91243
Recv:10:28:38.479: ok
Send:10:28:38.479: N961353 G1 X184 Y142.377 E1324.98686
Recv:10:28:38.503: ok
Send:10:28:38.503: N961354 G1 X186.114 Y135.879 E1325.20731
Recv:10:28:38.537: ok
Send:10:28:38.537: N961355 G1 X188 Y134.497 E1325.28275
Recv:10:28:38.856: ok
Send:10:28:38.856: N961356 G1 X188 Y153.019 E1325.88031
Recv:10:28:39.065:  T:196.90 /197.00 B:60.03 /60.00 @:37 B@:2
Recv:10:28:39.221: ok
Send:10:28:39.221: N961357 G1 X192 Y155.931 E1326.03994
Recv:10:28:39.579: ok
Send:10:28:39.579: N961358 G1 X192 Y131.566 E1326.82601
Recv:10:28:39.935: ok
Send:10:28:39.936: N961359 G1 X193.168 Y130.711 E1326.87271
Mesg:10:28:40.071: Connection closed by os during print ... trying reconnect for 10 seconds to continue ...
Mesg:10:28:40.779: Dtr: true Rts: true
Mesg:10:28:40.781: Connection continued
Send:10:28:40.792: N961360 G1 X196 Y130.711 E1326.96407
Send:10:28:40.792: N961361 G1 X196 Y156.783 E1327.80522
Mesg:10:28:44.804: Warning: Communication timeout - resetting communication buffer.
Mesg:10:28:44.804: Connection status: Buffered:82, Manual Commands: 0, Job Commands: 5000
Mesg:10:28:44.805: Buffer used:82 Enforced free byte:41 lines stored:2
Send:10:28:44.805: N961362 G1 X200 Y156.783 E1327.93427
Send:10:28:44.805: N961363 G1 X200 Y130.711 E1328.77541
Send:10:28:46.038: M117 Layer 406/1174
Mesg:10:28:47.808: Reconnecting usb port to fix serial driver problems ...
Mesg:10:28:47.926: Connection closed by os during print ... trying reconnect for 10 seconds to continue ...
Mesg:10:28:48.233: Dtr: true Rts: true
Mesg:10:28:48.236: Connection continued
Send:10:28:48.247: N961364 G1 X201.635 Y130.711 E1328.82816
Send:10:28:48.248: N961365 G1 X204 Y132.433 E1328.92254
Mesg:10:28:52.260: Warning: Communication timeout - resetting communication buffer.
Mesg:10:28:52.261: Connection status: Buffered:86, Manual Commands: 0, Job Commands: 5000
Mesg:10:28:52.261: Buffer used:86 Enforced free byte:41 lines stored:2

Comments

  • Nachtrag:

    Beim längsten Druck wähle ich immer "nach Druck herunterfahren" (Steckersymbol wird grün), weil anschließend sich die Steckdose abschaltet. Bei den letzten Druckaufträgen blieb aber nach Abschluss Repetier-Server immer aktiv. In den Logfiles kann ich aber keine Meldung zu einem fehlgeschlagenen Shutdown finden. Wie kann ich herausfinden, weshalb der Server nicht herunter fährt?
  • Mesg:10:28:40.071: Connection closed by os during print ... trying reconnect for 10 seconds to continue ...
    Mesg:10:28:40.779: Dtr: true Rts: true
    Mesg:10:28:40.781: Connection continued

    Das ist denke ich das Hauptproblem. Linux hat die usb verbindung getrennt. Ich würde in /var/log/syslog nachsehen was der genaue Grund ist. Der übliche Grund sind Spannungsprobleme - da hilft ggf. die 5V schiene am USB stecker abzukleben, siehe unsere FAQ zu spannungsprobleme, da ist eine Anleitung.

    Was das abschalten angeht - der Drucker muss noch online sein sonst werden die Befehle nicht übertragen. Wenn also der Drucker ausgeschalötet wird kann es sein das der Befehl danach nicht klappt weil der Server das schon gesehen hat oder halt noch nicht. In dem Fall shutdown zuerst aufrufen ggf. mit einem delay von ein paar sekunden. Ich glaub aktuell steht da shutdown -h now also sofort.
  • Danke für die schnelle Rückmeldung. Die 5V Schiene ist bei allen Druckern abgeklebt. Habe gerade nochmals geprüft, ob das Board unter Spannung steht, was nicht der Fall ist. 

    Falls ich das richtige Logfile erwischt habe, finde ich dort keinen entsprechenden Eintrag, sondern nur immer die gleichen.

    Jan 16 10:27:07 Repetier-Server dbus-daemon[403]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service' requested by ':1.507' (uid=0 pid=16992 comm="timedatectl ")
    Jan 16 10:27:07 Repetier-Server systemd[1]: Starting Time & Date Service...
    Jan 16 10:27:07 Repetier-Server dbus-daemon[403]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 16 10:27:07 Repetier-Server systemd[1]: Started Time & Date Service.
    Jan 16 10:27:37 Repetier-Server systemd[1]: systemd-timedated.service: Succeeded.
    Jan 16 10:28:08 Repetier-Server dbus-daemon[403]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service' requested by ':1.510' (uid=0 pid=17173 comm="timedatectl ")
    Jan 16 10:28:08 Repetier-Server systemd[1]: Starting Time & Date Service...
    Jan 16 10:28:08 Repetier-Server dbus-daemon[403]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 16 10:28:08 Repetier-Server systemd[1]: Started Time & Date Service.
    Jan 16 10:28:38 Repetier-Server systemd[1]: systemd-timedated.service: Succeeded.
    Jan 16 10:29:09 Repetier-Server dbus-daemon[403]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service' requested by ':1.513' (uid=0 pid=17267 comm="timedatectl ")
    Jan 16 10:29:09 Repetier-Server systemd[1]: Starting Time & Date Service...
    Jan 16 10:29:09 Repetier-Server dbus-daemon[403]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 16 10:29:09 Repetier-Server systemd[1]: Started Time & Date Service.
    Jan 16 10:29:39 Repetier-Server systemd[1]: systemd-timedated.service: Succeeded.
    Jan 16 10:30:11 Repetier-Server dbus-daemon[403]: [system] Activating via systemd: service name='org.freedesktop.timedate1' unit='dbus-org.freedesktop.timedate1.service' requested by ':1.516' (uid=0 pid=17364 comm="timedatectl ")
    Jan 16 10:30:11 Repetier-Server systemd[1]: Starting Time & Date Service...
    Jan 16 10:30:11 Repetier-Server dbus-daemon[403]: [system] Successfully activated service 'org.freedesktop.timedate1'
    Jan 16 10:30:11 Repetier-Server systemd[1]: Started Time & Date Service.
    Jan 16 10:30:41 Repetier-Server systemd[1]: systemd-timedated.service: Succeeded.


  • Grundsätzlich die richtige Datei könnte aber die falsche Stunde sein. syslog arbeitet mit utc denke ich und der server hat lokale Zeit. Bei mir ist da eine Stunde unterschied, müsstest also bei 9:28:40 gucken wenn du den gleichen versatz hast. 
  • Hui, ich bin mir da nicht so sicher. Mein Drucker läuft über den Port "/dev/serial/by-path/platform-fd500000.pcie-pci-0000:01:00.0-usb-0:1.2:1.0-port0"
    Wenn ich dann in der Logfile nur nach "1.2:0 suche, wirft er mir zu unterschiedlichen Zeiten folgendes raus:

    Jan 16 07:58:16 Repetier-Server kernel: [   80.784706] usbcore: registered new interface driver usbserial_generic
    Jan 16 07:58:16 Repetier-Server kernel: [   80.784736] usbserial: USB Serial support registered for generic
    Jan 16 07:58:16 Repetier-Server kernel: [   80.786755] usbcore: registered new interface driver ch341
    Jan 16 07:58:16 Repetier-Server kernel: [   80.786803] usbserial: USB Serial support registered for ch341-uart
    Jan 16 07:58:16 Repetier-Server kernel: [   80.786864] ch341 1-1.2:1.0: ch341-uart converter detected
    Jan 16 07:58:16 Repetier-Server kernel: [   80.790586] usb 1-1.2: ch341-uart converter now attached to ttyUSB0
    Jan 16 07:58:16 Repetier-Server mtp-probe: checking bus 1, device 4: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Jan 16 07:58:16 Repetier-Server mtp-probe: bus: 1, device: 4 was not an MTP device

    Jan 16 07:58:27 Repetier-Server kernel: [   92.068712] usb 1-1.2: USB disconnect, device number 4
    Jan 16 07:58:27 Repetier-Server kernel: [   92.069572] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
    Jan 16 07:58:27 Repetier-Server kernel: [   92.069704] ch341 1-1.2:1.0: device disconnected
    Jan 16 07:58:28 Repetier-Server kernel: [   93.326030] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32
    Jan 16 07:58:29 Repetier-Server kernel: [   93.331479] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32

    Jan 16 07:58:52 Repetier-Server kernel: [  116.838282] ch341 1-1.2:1.0: ch341-uart converter detected
    Jan 16 07:58:52 Repetier-Server kernel: [  116.843776] usb 1-1.2: ch341-uart converter now attached to ttyUSB1
    Jan 16 07:58:52 Repetier-Server mtp-probe: checking bus 1, device 7: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Jan 16 07:58:52 Repetier-Server mtp-probe: bus: 1, device: 7 was not an MTP device
    Jan 16 07:58:52 Repetier-Server mtp-probe: checking bus 1, device 7: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Jan 16 07:58:52 Repetier-Server mtp-probe: bus: 1, device: 7 was not an MTP device

    Jan 16 13:56:55 Repetier-Server kernel: [21599.816504] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32
    Jan 16 13:56:55 Repetier-Server kernel: [21599.946970] usb 1-1.2: USB disconnect, device number 7
    Jan 16 13:56:55 Repetier-Server kernel: [21599.947960] ch341-uart ttyUSB1: ch341-uart converter now disconnected from ttyUSB1
    Jan 16 13:56:55 Repetier-Server kernel: [21599.948033] ch341 1-1.2:1.0: device disconnected
    Jan 16 13:56:55 Repetier-Server kernel: [21600.298471] usb 1-1.2: new full-speed USB device number 11 using xhci_hcd
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444669] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444685] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444698] usb 1-1.2: Product: USB Serial
    Jan 16 13:56:55 Repetier-Server kernel: [21600.451444] ch341 1-1.2:1.0: ch341-uart converter detected
    Jan 16 13:56:55 Repetier-Server kernel: [21600.456884] usb 1-1.2: ch341-uart converter now attached to ttyUSB0
    Jan 16 13:56:55 Repetier-Server mtp-probe: checking bus 1, device 11: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Jan 16 13:56:55 Repetier-Server mtp-probe: bus: 1, device: 11 was not an MTP device
    Jan 16 13:56:55 Repetier-Server mtp-probe: checking bus 1, device 11: "/sys/devices/platform/scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.2"
    Jan 16 13:56:55 Repetier-Server mtp-probe: bus: 1, device: 11 was not an MTP device
  • Ja der ch341 ist wohl problematisch. Du siehst ja hier

    Jan 16 13:56:55 Repetier-Server kernel: [21599.816504] ch341-uart ttyUSB1: usb_serial_generic_read_bulk_callback - urb stopped: -32
    Jan 16 13:56:55 Repetier-Server kernel: [21599.946970] usb 1-1.2: USB disconnect, device number 7
    Jan 16 13:56:55 Repetier-Server kernel: [21599.947960] ch341-uart ttyUSB1: ch341-uart converter now disconnected from ttyUSB1
    Jan 16 13:56:55 Repetier-Server kernel: [21599.948033] ch341 1-1.2:1.0: device disconnected

    Da ist ein Fehler im Treiber aufgetreten und er trennt die verbindung. Hat also nichts mit Spannung zu tun sondern mit einem Fehlerzustand. Möglicherweise durch Kommunikationsfehler verursacht - klappt ja sonst ne ganze weile.

    Danach sieht er huch, da ist doch noch so ein usb gerät und verbindet wieder neu:
    Jan 16 13:56:55 Repetier-Server kernel: [21600.298471] usb 1-1.2: new full-speed USB device number 11 using xhci_hcd
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444669] usb 1-1.2: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444685] usb 1-1.2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    Jan 16 13:56:55 Repetier-Server kernel: [21600.444698] usb 1-1.2: Product: USB Serial
    Jan 16 13:56:55 Repetier-Server kernel: [21600.451444] ch341 1-1.2:1.0: ch341-uart converter detected
    Jan 16 13:56:55 Repetier-Server kernel: [21600.456884] usb 1-1.2: ch341-uart converter now attached to ttyUSB0
    Jan 16 13:56:55 Repetier-Server mtp-probe: checking bus 1, device 11: 

    Googelt man danach sieht man das es einige gibt die das Problem festgestellt haben. Hab z.b. von einem gelesen bei dem ging es auf dem pi 4 nicht wie hier. Selbe karte auf pi 3 ohne Probleme. Manche sagen usb auf usb 1 umstellen hilft, andere sagen bei ihnen nicht. Offenbar können kleine Änderungen schon zum Problem oder zur Verbesserung führen. Mag auch sein das ein neuerer Linux Kernel oder ein älterer hilft. Mit dem letztem image update hat sich auch der linux Kernel erneuert. Wenn du also das image aktualisiert hast kann es sich auch damit eingeschlichen haben.
  • I have similar issues since updating to V1.02, how can I roll back to 0.94.3 please, ? 0.94.3 was solid for me. I have Prusa Mk3s and Rasberry Pi 3b
  • Have 1.0.2 image on Pi 4 and no problems with Mk3s. Previously ha dit running on pi3+ also without problems. You should note that the discussed problem above comes from linux not server! Have you checked the syslog to also contain os disconnects?

    Anyhow, just download older deb package and install it with
    sudo dpkg -u name.deb 
    and you are back on old version.

    Did you just upgrade the server or also the linux image which has a newer kernel version?
  • edited January 19
    @Repetier

    Sorry I should have created a new post.

    I updated using the Pi Screen auto updater.

    Just to make sure the deb file for downgrade is

    Linux 32 bit ARM (armel): libc 2.13 like on Raspberry-Pi Raspian.

    I also can’t get the Timelapse working on new version, it has worked in the past. Never saves the video and loses settings on the web interface although it seems to set on the Pi Screen. ?

    Thanks
  • Normally armhf is better. armel is only required for pi 0 and pi 1.

    Timelapse has an option now to delete images after conversion (in general timelapse configuration).

    Timelapse settings on touch screen is also new. Which setting does not get stored for you?
  • edited January 19
    @Repetier

    The compiled video from the snapshots can’t be seen under recordings. And the settings aren’t saved when I access the interface via a web browser. Although they are on the Pi Touchscreen.

    I noticed one occasion the thumbnail of the gcode was being generated.

    Could both these issues be something to do with licensing? I have a license BTW.
  • Is there an error message for the conversion? Does recreating video work or ore the images missing?
    Is there enough disk space? When disk space gets low timelapse stops taking images.
  • edited January 19
    Repetier said:
    Is there an error message for the conversion? Does recreating video work or ore the images missing?
    Is there enough disk space? When disk space gets low timelapse stops taking images.
    no errors
    no video no images
    50gb free space on the card

    https://photos.app.goo.gl/C5gurawhP45QxQZ66
    https://photos.app.goo.gl/PvqGrJkPLHv9JcbY8

     Just to let you know ...
    1 / I looked at the server again this morning, things appeared ok, even the recordings were listed and timelapse settings were showing in the web browser interface .

    I moved around checking different settings in printer settings etc. I checked recordings again, they disappeared again, also timelapse settings were gone. Also tried to reboot or shut down the server from web interface this didn't work. the only way was to go to Pi touch screen to shut down. There a restart was not possible? so I had to pull the power doing a hard reboot. Yesterday I was getting the lightning bolt randomly to appear obviously indicating over voltage. That was ok eventually.

    2 / I've now gone back to 0.94.3, so far so good all is well again.

    Thanks


  • That looks bad. No values at all. Haven't seen that on my printers running 1.0.2 so wonder what is causing this. Looks like it fails to read the settings. Can you send me your printer xml config? Need to release new version tomorrow due to urgent bug, but if I see what make sit fail I fix that as well.
  • Repetier said:
    That looks bad. No values at all. Haven't seen that on my printers running 1.0.2 so wonder what is causing this. Looks like it fails to read the settings. Can you send me your printer xml config? Need to release new version tomorrow due to urgent bug, but if I see what make sit fail I fix that as well.
    Isn’t it too late now I’ve now graded to send you the xml config, where do I find it if it sent ? 
  • You never know if it is too late. In home screen it is  in the printer menu top left.
  • Ok, danke für die Erklärung. Also ist es jetzt eine Wahl zwischen Sodom und Gomorrha, weil es keine Lösung gibt.
    Entweder mache ich das Update rückgängig und habe Probleme mit der Verbindung meiner Fritzbox oder ich lasse es so und ein Drucker beendet keinen Druck mehr und ich verprasse weiter Filament.
    Sehe ich das so richtig?
  • @Cyrga Wenn du darauf anspielst das die neuen images den Treiber reloaden vermutlich. Du kannst zwar den server downgraden, aber ich vermute ja das es der neuere Treiber ist da ja linux(Treiber) hier die Verbindung trennen. Wobei im server ja extra wegen der Problematik die option ist bei usb Trennung sofort weiter zu drucken als ob nichts wäre. Solange die Treiber das also nur alle x stunden machen ist das durchaus eine Lösung die Drucke nicht ruiniert. Verbindung ist ja in der regel sehr schnell wieder da.
  • Repetier said:
    You never know if it is too late. In home screen it is  in the printer menu top left.
    I've finally worked out where to download the printer.xml how can I get it to you ?
  • Repetier said:
    See PM
    Sent you email.
Sign In or Register to comment.