3d touch z-probe problems

I have set-up a 3d touch (BL Touch clone) z probe on a ramps 1.4
I have followed the guide by "Pidgeon Print".
I am bench testing the set-up on a spare Ramps so nothing apart from the probe is connected.
When I power up the Ramps.. the probe does a self-test okay (the probe cycles in and out 2 times) and the red LED comes on.
However, I send the M340 P0 S700 or M340 P0 S1500 command and nothing happens.

I have tried the set-up on my printer and it does the same.

Any suggestions?


  • Have you configured a servo for the pin you connected the 3d touch to? When the servo commands do not work it either not using same pin or sensor has not enough power but since self test works I have to assume power is enough.

    Also recheck if the value shave the meanings you think. I think the correct servo positions do not have such smooth values and if you are outside the recognition range nothing will also happen.
  • Thanks @Repetier
    I have the three wire servo connector wired to Servo0 on the Ramps, I am assuming that I should select Digital Pin 11.  The two end stop connection is wired to Z-min ground and signal.
    I have checked and found other values for S so will try these as well.

  • The left servo should have 11. I always used the right one which has pin 4, but both should work as well.
  • In the firmware configurator there is Z-Probe Pin selection drop down...  I have selected Digital Pin 11 and in the Servo Configuration there is a Servo 0  Pin dropdown - I have selected Digital Pin 11 and start position of -1.
    It seems contradictory to have both configurations use Digital Pin 11 or is this correct?
    For the record I have Z-min as electronic NC and Pin z-min endstop
  • Yes, you have 2 cables so these are different pins. The servo pin must be 11 (or 4 if using right one) and the z probe pin is the one used for reading signals which is z min pin. This is unrelated to servo handling. Should be low when pin is loaded and only be high in error case.
  • edited December 2020
    I set up the servo pin and probe to pin 11 and tried the suggested M340 P0 S10 or S90 and I still get no response from the probe.
    Is there a way to test that a signal is being sent to the pin or a way of checking that I have communication to the pin?
  • try using 
    M340 P0 S700 or M340 P0 S1500 
  • > I set up the servo pin and probe to pin 11 
    That will not work. servo pin is 11, z probe pin is z min pin I think from your description. When you set it to 11 you make 11 an input so it is not controllable!
Sign In or Register to comment.