Printing issues Ultratronics & Repetier 1.0.5d


Just upgraded one of my Felix 3d 3.1 printers, containing a prusa e3d extruder, with Ultratronics Pro board, RADS128 drivers and LCD display 12864.

> Main reason : lets get less noise out of my printer :-)

I used Repetier development firmware v1.0.5d and configured with the online tool.

There is some issue selecting the STEP_DOUBLER_FREQ, you cannot type a value. It is set to 80000. After saving the config file the value is 12000 ?
Does anyone have a good config file example for Ultratronics + RADS128 drivers + 12864 Display ?

Next some strange effects:
- when setting heated bed manually it works just fine. Temperature will settle to requested value. But if i start printing via gcode, the temperature in the display is eg set to 45 deg, but actual value will rise further beyonbd setpoint.
- ocassionally when changing a config parameter file, the bed temperature sensor shows 0 all the time. Did not find exactly which parameter.... (not one of heated bed section)
- when printing gcode, it seems to start ok, but after some printing, it looks like it's going crazy directions. It misses part of 1st layer, or it suddenly poops an amount of filament at 1 place and then continues.
I tried a different SD card, but no improvements. Gcode export of Prusaslicer is set to Repetier type. Well it worked when i still had the original Felix controller installed with the same file.
Don't have z height correction enabled.

Looks like some gcode parts are skipped?

Does these issues sound familiar to someone ? 

Kind regards,



  • ok, found that eeprom file is generated onto SD card, but has size 0. Asuming SD card reading/writing is the problem.... Trying reduced SCK frequency. I do have app. 1 m cable between display and ultratronics board.... 

  • Ok 1m cable is a lot. Can cause problems with sd reading. Doesn't the board have it's own sd card slot as well. When you use that instead and configure it to use it - I think simple uncommenting the sd card settings in display settings in displaylist.h - it should work better.

    Temperatures especially the first time swing over set point which is quite normal. But not too much. Extruders could overswing 10-20°C on bad pid values. Bed I guess not that much.

    Bed temperature 0 is strange. As set point that means off but measuring it 0 would be an error normally.

    STEP_DOUBLER_FREQ switches between 12000 and 80000 when you switch processor type, haven't see changint it afterwards. You can change it manually in config file if it happened.

    >- when printing gcode, it seems to start ok, but after some printing, it looks like it's going crazy directions. It misses part of 1st layer, or it suddenly poops an amount of filament at 1 place and then continues.

    So you print form sd card? What you describe is that gcode is not as programmed. If you have read errors form sd card they go undetected as we have no checksums and then that might be the reason. So shorten cable or try internal or use repetier-server to exclude sd card.
  • Ok, thanks for the reply. I can report following progress:

    - tuned PID parameters for heated bed and extruder. (both controllers to PID)
    Extruder is ok
    Still have sometimes initial ~10 deg overshoot on the bed temp.
    Sometimes it just rises to 60 deg and then reports an error since it can not hold the requested temp.
    Could this be parameter / eeprom related ?

    SD read/write:
    - tried to use display with shorter cables, ~ 30 cm : still SD read/write issues. SD is mounted, but get error: Could not write eeprom to SD card. It does create an eeprom.bin file but with size 0.
    - tried to insert SD directly on unltratronics board: same SD read/write issues. 
    - disabled display in firmware, while SD on ultratronics board: eeprom.bin of 4K created. No errors writing eeprom.bin ! (display was still connected)

    So as soon as i enable the display (RepRapWorld GLCD v1.0) there seems to exist some SD card read/write issue.

    Used Repetier host to print some gcode : no strange printing behaviour (except that not all printer settings are optimal) 

    So i guess this points to some Display / SD card issue - conflict. 

    Is it possible to disable the on board SD card reader in software ?
    Would like to use the one on the display only because its easier to reach.

    Any hints that i can try ? Thanks.
  • ok, after modifying config.h and downloading to the board, readout of eeprom M205 shows wrong values for bed temp pid. 
  • Normally the display controller disables the board sd card anyway. It switches the sd detect and ship select pin to use the one on display. Without controller the pins from board take over. Just make sure only one sd card is inserted also even that should work as it is not selected active.

    What is strange is that you can see the files - means pins are defined correctly. So the problem must be with timing or voltages. sd cards need 3.3v but some displays are for 5v displays as well and have a voltage regulator. The ultratronics uses 3.3v normally. But that is hard to say if that could be a problem.

    > Sometimes it just rises to 60 deg and then reports an error since it can not hold the requested temp.
    Could this be parameter / eeprom related ?

    What was the target temperature set when it raises to 60°C? PID for beds are a bit harder so it might be that you just must relax the conditions. You need to check the temperqture graph including output power over time. That it is normally easy to see if it is just bad pid setting or a real problem.
  • Hi,
    When i have the display connected and enabled in firmware, the system accepts the SD card in both slots (1 at a time). Meaning both slots seem active. Is the switching/selection done in firmware or hardware?
  • That would only work if both need the same slave select and sd card detect pin. But if you can list files when inserted and can't when not inserted it should be ok.
  • Ok, i’ve Googled on sd card issue ultratronics and display, looks like issue appears as soon as display is enabled. Will try to disable display and then test sd card on display sd interface....
  • Hi,
    I disabled display in FW. Now SD card works ok in either display entry or via main board.
    So enabling LCD will mesh up SD card read/write.

  • What is the difference between software and hardware SPI ?
    If i enable LCD display, software SPI is activated. If i uncomment these defines and goto hardware SPI, display only shows startup screen then freezes. But SD card works. 
  • Ok good progress. Hardware SPI is what we use for sd card reading. It is very fast since we just say send byte and hardware toggles pins it set frequency.

    Software SPI is same just do we change pins manually. So gets a bit slower.
    Problem is when a display uses spi for visualization and sd card. Then they share same pins and with hardware spi you can often not manipulate the pins manually. So that must match. 

    The RRD display for example has different pins. So here we have hardware spi for sd card and control and use software spi for the display function. In that case it is also good because the driver is very sensitive to timings and quite slow, so with software spi it works much better. Its the ST7920 chip.

    As it looks you use same pin so try configuring sd card to use software spi and same for display. Actually looking into pins.h for ultratronics I already see

    // --- Use software SPI since display does otherwise not work, remove to use hardware SPI
    #define DUE_SOFTWARE_SPI
    #define SD_SOFT_MISO_PIN 74
    #define SD_SOFT_MOSI_PIN 75
    #define SD_SOFT_SCK_PIN 76
    // --- end switch to software SPI

    so that seems in deed be the problem. Use for display also software spi.
  • Hi, yes indeed the display and SD use same spi pins. If i remove/comment the software spi code, the display does not work, but SD card does. However display does show repeteer startup screen ! But that screen remains.
    If i uncomment software spi defines, the display works, but SD card cannot read/write. Init Sd card seems ok in that case.
  • Hi,
    Issue still not solved :-( 
    So i do use the DUE_SOFTWARE_SPI, but then i keep having issues with my SD card. It initializes / mounts ok, but all other actions, reading/writing goes wrong. So software SPI does not seem to work with my SD for some reason. When i switch to hardware SPI, the SD card works ok, but the display not. 

    I hope there are Ultratronics users that have graphical LCD screen (RepRapWorld GLCD v1.0) with SD working ?
    Can someone confirm this ? 
  • ok, tried to run LCD test firmware -> SD card not ready
    Measured 3V3 supply on the LCD : 4.0V ! will replace LDO regulator and see if this brings something....
  • LDO swap didn't improve, but at least i now have 3.3V supply for SD.
    So just running Ultratronics (409) with LCD reprap display in software SPI mode. Here's my logging from repetier server. You can notice that card is succesfully initialized. It can even read the eeprom file (generated earlier in hardware SPI mode). It even does succesfull SD list. But then it cannot write to SD.
    If i delete the eeprom file via PC, one will be generated with size 0 bytes. Deletion via rep server does not work (see last logging). Do i also see a WDT timeout (wat) ?

    19:55:45.453 : start
    19:55:45.453 : Info:PowerUp
    19:55:45.691 : N1 M110*34
    19:55:45.691 : N2 M115*36
    19:55:45.691 : N4 M114*35
    19:55:45.691 : N5 M111 S6*98
    19:55:52.089 : Free RAM:82116
    19:55:52.219 : Card successfully initialized.
    19:55:52.231 : EEPROM read from sd card.
    19:55:52.231 : Detected EEPROM version:20
    19:55:52.244 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
    19:55:52.244 : SelectExtruder:0
    19:55:52.245 : N6 T0*60
    19:55:52.334 : N7 M20*22
    19:55:52.352 : Cap:PROGRESS:1
    19:55:52.354 : Cap:AUTOREPORT_TEMP:1
    19:55:52.354 : Cap:HOST_RESCUE:1
    19:55:52.359 : Cap:EEPROM:1
    19:55:52.359 : Cap:AUTOLEVEL:0
    19:55:52.359 : Cap:Z_PROBE:0
    19:55:52.362 : Cap:SOFTWARE_POWER:1
    19:55:52.362 : Cap:TOGGLE_LIGHTS:0
    19:55:52.362 : Cap:PAUSESTOP:1
    19:55:52.366 : Cap:PREHEAT:1
    19:55:52.366 : Cap:EMERGENCY_PARSER:1
    19:55:52.374 : Printed filament:0.00m Printing time:0 days 0 hours 0 min
    19:55:52.374 : PrinterMode:FFF
    19:55:52.375 : N8 M80*19
    19:55:52.392 : X:0.00 Y:0.00 Z:0.000 E:0.0000
    19:55:52.392 : DebugLevel:6
    19:55:52.392 : N10 M220 S100*80
    19:55:52.393 : SelectExtruder:0
    19:55:52.393 : Begin file list
    19:55:52.393 : N11 M221 S100*80
    19:55:52.394 : eeprom.bin 4096
    19:55:52.395 : End file list
    19:55:52.395 : N12 M111 S6*84
    19:55:52.396 : N13 T0*8
    19:55:52.400 : N14 M155 S1*85
    19:55:52.404 : DebugLevel:6
    19:55:52.408 : SelectExtruder:0
    19:56:00.432 : Error:Could not write eeprom to sd card
    19:57:01.131 : wat

    Tried deleting eeprom file:
    19:59:14.626 : N15 M30 eeprom.bin*79
    19:59:14.634 : Deletion failed

  • wat is wait with missing i not a watchdog triggering. It looks like eeprom is read at the beginning but can nbe written/deleted.
    Have you tried reformatting with sdformat. Not that the directory structure is just defective. Because it is quite strange that parts work and other parts not.
  • Hi, formatting with special SD format did not help.
    Switched to Marlin FW to exclude some HW issue.
    No issues with LCD in combination with SD card. All functioning fine now...... 

Sign In or Register to comment.