Help with bltouch

edited October 6 in Repetier-Firmware
Hi. How are they.. I have two problems, the first with my zonda bltouch sensor, the sensor seems to work fine, they change their state from low to high. But Z-min, it is always low, it does not change, but it is the same pin.WTF

02: 06: 26.306: endstops hit: x_min: L y_min: L z_min: L Z-probe state: H
02: 06: 32.351: endstops hit: x_min: L y_min: L z_min: L Z-probe state: L

MY solution is to comment on some lines in Endstops.cpp

#if FEATURE_Z_PROBE
#if Z_PROBE_PIN == Z_MIN_PIN && MIN_HARDWARE_ENDSTOP_Z
  if (newRead & ENDSTOP_Z_MIN_ID) // prevent different results causing confusion
    newRead |= ENDSTOP_Z_PROBE_ID;
    
    //by david
//  if (!Printer::isHoming())
//    newRead &= ~ENDSTOP_Z_MIN_ID; // could cause wrong signals depending on

    
                                  // probe position
#else
  if (Z_PROBE_ON_HIGH ? READ(Z_PROBE_PIN) : !READ(Z_PROBE_PIN))
    newRead |= ENDSTOP_Z_PROBE_ID;

It works, but I don't know if it brings problems with the G32 AND G33 code

02: 01: 46.827: endstops hit: x_min: L y_min: L z_min: L Z-probe state: L
02: 01: 49.944: endstops hit: x_min: H y_min: L z_min: H Z-probe state: H

MY OTHER PROBLEMS IS WHEN I enable the bluetouch, it seems to work, well, it connects, well, it shows correct information. but the bltouch, no longer works, does not change its state. any solution? I am using, arduino mega 2560 and ramp 1.4

Comments

  • First it is correct that z_min stays low. That is intentional since it is the z probe that can trigger already for z > 0 so it might prevent going down on some sensors preventing z hop on first layer. Also note that bltouch only keeps signal for 100ms after triggering so measuring it with M119 is not reliable - that is ok as well. If it keeps high it is in error state and at least the original is also blinking the led. Then you need to reset the bltouch to work again. The M340 command to do so is on the bltouch homepage. So if you say it stops working I assume the error state it is. It goes to error state in 2 conditions:
    1. Stow pin/deploy pin did not work.
    2. After triggering you need to move up fast cause after a short time pin is released and if you are not up high enough it keeps being triggered starting alarm state.
  • edited October 6
    I USE THE MODE TEST M340 PO S1200, WHICH ALLOWS TO VERIFY THE STATUS OF 
    THE bLtOUCH SENSOR. and Zmin is always low. I don't have another sensor connected to
    the Zmin pin - only the BlTouch is connected. It has not been used since the
    Repetier-Firmware configuration tool for version 1.0.0,
    and the truth is that most of the time the g33 does not work for me.

  • There is to control the speed of the blTouch when it goes down and up.
    
    What I see is that when it goes down it does it fast, and when it goes up it does it more slowly ... I think it should be the other way around


  • I SEE THAT THE SPEED THAT GOES DOWN THE ZONE IS THE SAME AS 
    THE SPEED IT GOES UP,
    HOW CAN I MODIFY SO THAT I CAN GO UP FASTER AND SLOWER WHEN GOING DOWN?


  • Down speed is Z-probe speed from eeprom.Up speed is homing feedrate for z axis.
  • hi, this one doesn't work for me with g30 g33, it's still the same speed of
    Z-probe speed
    
    
    But if I do a homing in Z, I see a big change in speed




  • HELLO, NOW it seems to work, update everything again, it seems to work .....
    
    but now I appreciate this ... I have never appreciated

  • edited October 8
    ..... IT WORKS, BUT WHEN I ENABLE THE BLUETOUCH the z-probe is always on high


    with the version Repetier-Firmware configuration tool for version 1.0.3 ... 

    it works for me with bluetouch, and it works on the graphics



  • You are confusing me. You say it is always high and you are saying it is working. At start it should be sucked in and it should be low. So if it is not in alarm mode and pin is stowed and pin is high you should normally need to invert the signal.
Sign In or Register to comment.