Cannot download Repetier-host for Windows

I recently acquired an old XYZ Da Vinci 1.0 and after reading plenty on line about the problems this printer had I upgraded to Repetier firmware. The compilation and download process went well and I can control the printer through the menu system.

Next I tried to download Repetier-Host for Windows. I got to the donation page but the download does not start. I tried again, made a donation, and again am returned to the download page and the download is not progressing in the background. I have tired 3 different PC with the same result:
  1. sometimes I am directed to the donation page where clicking 'download without donation' takes me back to the top of the download page;
  2. or the link has no effect and nothing happens
As mentioned I have tried three different PC, have tried Chrome, Chrome Incognito and Edge browsers - all with the same result. I also turned of the Chrome Safe Browsing feature at one point but it made no difference.

So, I have come to the conclusion there could be a problem with the web site, hence this post. Hopefully it is not finger trouble!

Is the download available as a ZIP?



  • Tried the continue without donation link and it send me correctly to

    So that seems to work. Then select the windows version for download. It is an exe file no zip available. Download link in this case would be and should start when clicked. Except if you have some filter preventing exe downloads.
  • Thanks for confirming the site is behaving as you expect.

    I have tried Google Chrome again after looking through all possible settings but it still doesn't commence the download so 'somewhere' it must be applying a filter as you suggest.

    I have tried again with Edge and this time it was successful - don't know what changed between attempts.

Sign In or Register to comment.