G02 and G03 code issue

Dear Experts!

My 3D printer not interpreting this code:
G03 X99.310635 Y20.941124 Z-0.125000 I-5.784536 J6.163855
G02 X89.944938 Y25.238500 Z-0.125000 I11.597644 J-10.953337

This code was generated by the inkscape laser tool.

The 3D printer does not execute any similar line.



  • Make sure in config tool->Features to have

    Enable arc support (G2/G3)

    enabled or you won't have these commands.

  • Ok. Thank you...
    But, where to find this options?
  • Well, meanwhile I found it:
    Enable arc support (G2/G3): is checked.

    Is the G02 format good, or G2?

  • I found in the configurator, but don't found in the configure.h.

    This is it?: #define ARC_SUPPORT 1 
  • Yes
    G02 X89.944938 Y25.238500 Z-0.125000 I11.597644 J-10.953337

    is correct format also I normally just write G2. Problem might be negative Z value. Normally you can not move below z=0 so that would cause a illegal position and be ignored. Except if you moved up after homing and used G92 Z0 to mark that position zero. Then you can go as low as Z when sending G92.
  • Wery well!

    If I delete the negative Z data then the 3D printer is work.

    Thank you your advice!
Sign In or Register to comment.