X axis direction difficulty

I need some help here with a problem, I have spent literally weeks trying to get my Mendel printer working, The Z and  Y axis home perfectly but cannot get the X axis to home. Have downloaded every firmware available but none solve the problem, am currently using the latest Repetier firmware and is the best yet, however still cannot get config.h sorted out to properly home X axis.  I have left and right movement using Repetier Host manual setting, there is 5 volts at the endstop, the mechanical endstop functions normally when manually activated, the endstop cuts power to the X axis when moving away from home but not towards home. No amount of setting changes make any difference to this situation.  The board is Arduino Mega 1.4 Ramps 2650. So what's going on, does anyone know?

All advice appreciated

The Tooluser


  • Check endstop status with M119

    Tell us what happens when you home. All we know is it does not work, but not what part is not working.
  • So how do I do that as I have been through the examples and can't find anything that looks like running M codes?
  • Depends on software you use. In host it is in manual control if easy mode is disabled. Server has it in console tab.
  • OK found that, but what is the correct command line and where does it display results?
  • M119

    is the command line and results show up in the log window at the bottom (easy mode disabled, toggle log if necessary).
  • Tried M119 3 days ago and got zero results which is why I sought confirmation of code string and output. Have tried again and get zero results (nothing, zip, zilch, etc.) so to toggle log, where have they hidden the log, how do I find it?
  • OK, found it! large type icon at top of screen, will check data and get back to you with details, thanks.
  • No useful data in log,

    20:07:59.346 : start
    20:07:59.346 : Info:External Reset
    20:07:59.362 : Transformation matrix: 1.000000 0.000000 0.000000 0.000000 1.000000 0.000000 0.000000 0.000000 1.000000
    20:07:59.362 : Free RAM:4437
    20:07:59.581 : N1 M110 *2
    20:07:59.581 : N1 M110 *2
    20:07:59.581 : N2 M115 *4
    20:07:59.581 : N3 M105 *4
    20:07:59.581 : N4 M114 *3
    20:07:59.581 : N5 M111 S6 *66
    20:07:59.581 : N6 T0 *28
    20:07:59.581 : N7 M20 *54
    20:07:59.581 : N8 M80 *51
    20:07:59.612 : N9 M220 S100 *72
    20:07:59.612 : N10 M221 S100 *113
    20:07:59.612 : N11 M111 S6 *119
    20:07:59.612 : N12 T0 *41

     unable to add M119 to log by typing command in gcode editor, so in line 1, I type M119 (enter) is there some other way to input this line? nothing different shows in the log

  • This is what I get, please tell me why x axis is not homing, please note endstops have not hit as there is nothing touching.

    19:40:23.461 : endstops hit: x_min:L x_max:L y_min:L z_min:H

    19:40:29.430 : N16 M105 *48

    19:40:29.618 : N17 M119 *60

    19:40:29.618 : endstops hit: x_min:L x_max:L y_min:L z_min:H

  • So homing x does nothing not even enabling motor? Need more information. Endstops are not high so moves are at least allowed.
  • Motor is enabled when manually moving to home position but endstop does not activate. If it is moving away from home then endstop functions normally. X axis will not home at all but Y and Z axis do. Any ideas?
  • There is a a parameter ALWAYS_CHECK_ENDSTOPS that if set 0 prevents endstop detection on manual moves.

    If x home does nothing you might have set x length to 0. Homing goes 1.5*x length to home position. Check eeprom for this value.
  • Problem Solved, If Y axis is working normally why not apply the same firmware parameters to X axis? It Works!  Now to solve a few more problems....
Sign In or Register to comment.