Problem loading firmware

I am trying to load Repetier firmware on two Arduino mega ramps 1.4 main boards with Reprap Smart Controllers.
I have tried loading 1.0.4 and 0.92.9 firmware.
Both appear to successfully load and I get a steady green LED on the main board.
However, all I get is an empty backlit screen.
One printer is fully built and has a power supply and I tried loading the firmware with no success.
As a double check I have just tried the second Arduino off the machine and got the same result.
I have successfully built another machine and these two are clones of the first.
I had no major problems loading the firmware in the very first machine.
Any hints at what I am doing wrong now.


  • I have cured it....  I reduced the contrast on the pot, and low and behold the screen displays the text now!!!!
  • well one of the boards seems to work okay... the other now has text on the display....  However, it appears to be constantly cycling through the start-up and the green LED is flashing at the same rate.
    Have I damaged the board in some way????
  • Do you have something like Repetier-Server installed that might try to reconnect constantly and fails, but still causes the reset?

Sign In or Register to comment.