How to solve SD card reading problem

I'm trying to use Repetier firmware on my milling/engraving CNC3018. I use Arduino Mega 2560 R3+RAMPS1.4+RepRapDiscount Full Graphic Smart Controller. Just today I've compiled first Repetier firmware and load it into hardware. Preliminary testing is O.K: steppers run manually from encoder, LCD is O.K. The problem is SD card reading. It writes, "LCD inserted", but any file (8+3 named) is not visible. This SD card works good in my PRUSA I3 (Marlin Firmware) printer. I tried to format SD card FAT16, FAT 32, but also without success. Would you please help me to solve this problem?


  • Also I tried to use RepRapDiscount Smart Controller with SD card reader. So I compiled above mentioned sketch with only changed name of display to Smartcontroller from RepRapDiscount on a RAMPS or RUMBA board. But I've not got any information on LCD. It only lights without any letter...

  • LCD Smartcontroller from RepRapDiscount  already works. The problem was the wrong position of contrast potentiometer. SD card files are visible and available for work. But how to implement RepRapDiscount Full Graphic Smart Controller? It still doesn't work with SD.

  • Actually they work the same using same settings as the 20x4 RRD display. But sometimes the cables have a connection problem. Try replacing the SD card cable with the one where it worked.
  • SD card slots are integrated in both displays (no cables). I already changed 2 cables between RAMPS and LCD displays. They work the same as before: LCD Smartcontroller from RepRapDiscount works good, and 
    RepRapDiscount Full Graphic Smart Controller is not able to use SD. Do you have any idea?
  • Switching the 2 cables was what I meant. Both use identical sd card settings so I assumed one had a fault. Both displays are the most used one so I also assume that it normally works or I would have much more complains. But currently I have no idea why except if you use some pins on it for other uses, but that is also unlikely if you had one working and only changed FEATURE_CONTROLLER to 11.
    Actually you can test with FEATURE_CONTROLLER 2 which worked and then connect the graphic version. Display of course will not work but using e.g. Repetier-Host you should be able to see the sd card when mounted. They are on same pins.
  • Today I've got the same another 12864 controller from our domestic supplpyer. It reads SD card without problems. Many thanks for your support...
Sign In or Register to comment.