Repetier Host Not Responding

I have a new Windows 7 64Bit PC that can run Repetier Host but the application randomly comes up and says "Not responding"
I then need to force shutdown and restart.
This can happen without even being connect to my printer (Prusa I3).
If I run this on my old Windows 7 32bit I have no problems and can run for many hours with issues.
But Windows 8.1 64Bit and Windows 7 64Bit both randomly crash application.
Same Printer, same cables etc.
Any ideas??? Can Repetier-Host successfully run on 64bit systems or do I have something else missing???
Please help.


  • The host runs on 64 bit systems. In fact we only test it on 64 bit systems.

    What does the crash report say? You might either see it in the message with details or in windows event log. There you see in which component it crashes. Often that component has a error. Last time a user could solve it by upgrading .NET to 4.6 which reinstalled all net libraries.
  • It's strange that I run it on 2 completely different PC's 1 windows 7 the other windows 8.1 bit 64bit and both randomly hang.
    But I can run on Windows 7 32bit and it works. 
    I have also just completed a print with Windows 7 32bit on a VirtualBox on my new Windows 7 64bit and it worked fine???

    Anyway, I will upgrade .NET to 4.6 and see what happens.

    When RH stops, it just says "Not Responding" in the task bar and EventViewer says it is no longer responding with windows.
    Not much information unfortunately.
  • Ok, that not responding normally means software is busy and does not react on events. The only case where I get this is when the serial connection gets corrupted somehow. At least every time it happens and I click pause in my debugger it is running a serial command where it waits for. Have you tried putting a usb hub (active) between printer and computer? I think it is not 64 bit I guess it is more the usb connection. On the other side then I would guess the virtual win 32 would have the same problem.

    What usb driver did you need? Was this signed? Also I think signing and not signing might not make it hang.
  • I didn't install any USB driver on Windows 7 32bit, just used what windows found.
    After having issues in Windows 7 64bit I installed the latest FTDI USB Serial driver from and still have the same issue. Is there a driver you recommend?
    I have also installed .NET to 4.5.3 (Latest version available) and still have the issue of it randomly "Not Responding"

    The Log file shows:
    > 15:19:16.660 : ok
    < 15:19:16.660 : N59484 G1 X101.367 Y95.269 E96.39958 *68
    < 15:19:16.660 : N59485 G1 X102.418 Y95.551 E96.46345 *75
    > 15:19:16.723 : ok
    < 15:

  • So you have a board with ftdi chip? I guess you have also installed arduino IDE which installs many drivers making most boards run.

    If you connect to the virtual printer (in ptinter settings just select virtual printer as connector). does it still stop working. That way we eleminate the serial communication part to see if it is that part causing the hang (whcih it normally is).
  • I can run RH on a VirtualBox Windows 7 32Bit system without fail for over 12hours so far, on my Windows 7 64bit PC that can't run RH???
    While RH on the VirtualBox was running, I opened RH on the Win7 64Bit PC, with no connection to printer (as VBox was running) RH came up again with Not Responding.
    I haven't directly installed any drivers in Win7 on VBox, windows found FTDI driver and it all works fine.

    No RH didn't stop responding when I set changed the printer settings to Virtual printer, so this would still look like a communication issue but where to look next???

    I have this same issue on 2 different PC's, Win8 64Bit and Win7 64 Bit, with completely different hardware.
    1 with ASRock Motherboard and the other with Gigabyte motherboard, both with same issue.

    I installed Arduino on 64Bit PC and it didn't find any drivers, so I reinstalled FTDI and it was talking again.

    My printer is Prusa I3 with MKS Gen2Z V1.1 board.

  • I let RH run all day when connected to a virtual printer and it came up with Not Responding.
    So this would indicate that it isn't the USB communication issue???
  • Can you try with filament visualization disabled. I think while printing there might be a threading issue that causes an error, also you then normally see a "Out of video memory error" when it happens, it might be the hang you get. If it is I can send you a test version where I hope to have solved this problem. 
  • I set filament visualization to disabled and it still comes up with not responding.
    I also have the printer still set to virtual printer.
    It doesn't actually crash it just hangs and doesn't write anything in the event log until a force a shutdown.
  • Immediately after installing, Repetier Host ran just fine but ever since I get the message "Repetier Host is not responding"
    Problem Log follows:
    Problem signature:
      Problem Event Name:    CLR20r3
      Problem Signature 01:    RepetierHost.exe
      Problem Signature 02:
      Problem Signature 03:    597f4ac2
      Problem Signature 04:    mscorlib
      Problem Signature 05:    4.7.2114.0
      Problem Signature 06:    59a63ab8
      Problem Signature 07:    32d
      Problem Signature 08:    10
      Problem Signature 09:    System.ArgumentException
      OS Version:    6.1.7601.
      Locale ID:    1033
      Additional Information 1:    4def
      Additional Information 2:    4def3b33d7c7278176a1e1e2092c5cd4
      Additional Information 3:    30a2
      Additional Information 4:    30a27a7c1d15bbe687315cfa91ed7087
    Can you help please?

  • That error message can mean anything. Please make sure .NET 4.0 or higher is installed and run a .net integrity check in admin console:
    sfc /scannow

  • 4.6 installed. Was able to run sfc.exe but it happened so fast I could not tell what happened. Can you provide help with how to run sfc/scannow?
    Have been able to run 1.5.6 OK.
  • open a cmd window then type it into the window. If you are not logged in as Administrator it will tell you so and not run. That might be why it ran so fast. (happened to me).
  • repeitier host connects to my Anet A8 but does not operate the printer

  • Then baud rate is set wrong in most cases. It connects to a serial device but does not understand anything. See also log with ack enabled if you get any readable responses.
Sign In or Register to comment.