Timelapse failed because not disc space ... due to images not deleted after successful rendering

after only 20-30 recordings on my raspberry all following timelapse recordings are failing.
The reason is that disc space is very low. This is because the images from the timelapse recrodings are not deleted after successful rendering. Required disc space for about 20-30 recordings is about 2GB based on my settings.

I really do not need to single images after successful rendering. Is there any possiblity to automatically delete the images after the timelapse have been rendered successful? Please provide solution for this. Thanks



  • The videos were never meant to stay. The idea is to download the video if you need it and then delete the timelapse. You can also move the video to a project and then delete the timelapse. But regardless of what you do even if it uses less disk space that way it will still fill your disk.

    A function to delete the images is noted for future versions. I think even as option to do this always might be nice here on own risk. Once deleted it is of course not possible to rerender with different parameter.
  • I am coming from Octoprint and on my Pi i have timelapse from the last three years without any disc space problem.
    The images require much more space than the rendered video. Option to disable is really necessary because i think about 90% of the users are not interested to re-render the timelapse again. For someboy who want to tweak the timelapse to have the best outcome it might be interesting but as said the majority of the users will not needed and therefore it should be made optional.
  • Hence the option I mentioned to add. That way you can decide. But I think you are right that making it enabled by default might be a good idea.
  • Thanks for fast implementation in v0.94.1_beta.
    I am currently testing this version.
  • Great, but don't forget to update to final 0.94.1 once I have collected all fixes:-)
Sign In or Register to comment.