Enable Z-probing

edited June 11 in Repetier-Firmware
The sensor is X + 20 away from the extruder. This is the settings I made. I'm getting an error

Comments

  • <?xml version="1.0" encoding="utf-8"?>
    <Repetier-Firmware-EEPROM>
    <epr pos="1028" type="0" value="10">Language</epr>
    <epr pos="75" type="2" value="115200">Baudrate</epr>
    <epr pos="129" type="3" value="949.004">Filament printed</epr>
    <epr pos="125" type="2" value="1021047">Printer active</epr>
    <epr pos="79" type="2" value="0">Max. inactive time</epr>
    <epr pos="83" type="2" value="360000">Stop stepper after inactivity</epr>
    <epr pos="3" type="3" value="200.0000">X-axis steps per mm</epr>
    <epr pos="7" type="3" value="200.0000">Y-axis steps per mm</epr>
    <epr pos="11" type="3" value="800.0000">Z-axis steps per mm</epr>
    <epr pos="15" type="3" value="200.000">X-axis max. feedrate</epr>
    <epr pos="19" type="3" value="200.000">Y-axis max. feedrate</epr>
    <epr pos="23" type="3" value="2.000">Z-axis max. feedrate</epr>
    <epr pos="27" type="3" value="40.000">X-axis homing feedrate</epr>
    <epr pos="31" type="3" value="40.000">Y-axis homing feedrate</epr>
    <epr pos="35" type="3" value="2.000">Z-axis homing feedrate</epr>
    <epr pos="39" type="3" value="20.000">Max. jerk</epr>
    <epr pos="47" type="3" value="0.500">Max. Z-jerk</epr>
    <epr pos="133" type="3" value="0.000">X min pos</epr>
    <epr pos="137" type="3" value="0.000">Y min pos</epr>
    <epr pos="141" type="3" value="0.000">Z min pos</epr>
    <epr pos="145" type="3" value="200.000">X max length</epr>
    <epr pos="149" type="3" value="200.000">Y max length</epr>
    <epr pos="153" type="3" value="120.000">Z max length</epr>
    <epr pos="1056" type="3" value="0.000">Park position X</epr>
    <epr pos="1060" type="3" value="0.000">Park position Y</epr>
    <epr pos="1064" type="3" value="10.000">Park position Z raise</epr>
    <epr pos="51" type="3" value="1000.000">X-axis acceleration</epr>
    <epr pos="55" type="3" value="1000.000">Y-axis acceleration</epr>
    <epr pos="59" type="3" value="100.000">Z-axis acceleration</epr>
    <epr pos="63" type="3" value="1000.000">X-axis travel acceleration</epr>
    <epr pos="67" type="3" value="1000.000">Y-axis travel acceleration</epr>
    <epr pos="71" type="3" value="100.000">Z-axis travel acceleration</epr>
    <epr pos="1024" type="3" value="0.000">Coating thickness</epr>
    <epr pos="808" type="3" value="2.000">Z-probe height</epr>
    <epr pos="929" type="3" value="10.000">Max. z-probe - bed dist.</epr>
    <epr pos="812" type="3" value="2.000">Z-probe speed</epr>
    <epr pos="840" type="3" value="150.000">Z-probe x-y-speed</epr>
    <epr pos="800" type="3" value="20.000">Z-probe offset x</epr>
    <epr pos="804" type="3" value="0.000">Z-probe offset y</epr>
    <epr pos="816" type="3" value="0.000">Z-probe X1</epr>
    <epr pos="820" type="3" value="0.000">Z-probe Y1</epr>
    <epr pos="824" type="3" value="160.000">Z-probe X2</epr>
    <epr pos="828" type="3" value="0.000">Z-probe Y2</epr>
    <epr pos="832" type="3" value="0.000">Z-probe X3</epr>
    <epr pos="836" type="3" value="160.000">Z-probe Y3</epr>
    <epr pos="1036" type="3" value="0.000">Z-probe bending correction A</epr>
    <epr pos="1040" type="3" value="0.000">Z-probe bending correction B</epr>
    <epr pos="1044" type="3" value="0.000">Z-probe bending correction C</epr>
    <epr pos="880" type="0" value="0">Autolevel active (1/0)</epr>
    <epr pos="1048" type="1" value="55">Bed Preheat temp.</epr>
    <epr pos="106" type="0" value="0">Bed Heat Manager</epr>
    <epr pos="107" type="0" value="255">Bed PID drive max</epr>
    <epr pos="124" type="0" value="80">Bed PID drive min</epr>
    <epr pos="108" type="3" value="196.000">Bed PID P-gain</epr>
    <epr pos="112" type="3" value="33.000">Bed PID I-gain</epr>
    <epr pos="116" type="3" value="290.000">Bed PID D-gain</epr>
    <epr pos="120" type="0" value="255">Bed PID max value</epr>
    <epr pos="1020" type="0" value="0">Enable retraction conversion</epr>
    <epr pos="992" type="3" value="3.000">Retraction length</epr>
    <epr pos="1000" type="3" value="40.000">Retraction speed</epr>
    <epr pos="1004" type="3" value="0.000">Retraction z-lift</epr>
    <epr pos="1008" type="3" value="0.000">Extra extrusion on undo retract</epr>
    <epr pos="1016" type="3" value="20.000">Retraction undo speed</epr>
    <epr pos="200" type="3" value="370.000">Extr.1 steps per mm</epr>
    <epr pos="204" type="3" value="50.000">Extr.1 max. feedrate</epr>
    <epr pos="208" type="3" value="20.000">Extr.1 start feedrate</epr>
    <epr pos="212" type="3" value="5000.000">Extr.1 acceleration</epr>
    <epr pos="294" type="1" value="190">Extr.1 Preheat temp.</epr>
    <epr pos="216" type="0" value="3">Extr.1 heat manager</epr>
    <epr pos="217" type="0" value="230">Extr.1 PID drive max</epr>
    <epr pos="245" type="0" value="40">Extr.1 PID drive min</epr>
    <epr pos="218" type="3" value="7.0000">Extr.1 PID P-gain/dead-time</epr>
    <epr pos="222" type="3" value="2.0000">Extr.1 PID I-gain</epr>
    <epr pos="226" type="3" value="40.0000">Extr.1 PID D-gain</epr>
    <epr pos="230" type="0" value="255">Extr.1 PID max value</epr>
    <epr pos="231" type="2" value="0">Extr.1 X-offset</epr>
    <epr pos="235" type="2" value="0">Extr.1 Y-offset</epr>
    <epr pos="290" type="2" value="0">Extr.1 Z-offset</epr>
    <epr pos="239" type="1" value="1">Extr.1 temp. stabilize time</epr>
    <epr pos="250" type="1" value="150">Extr.1 temp. for retraction when heating</epr>
    <epr pos="252" type="1" value="0">Extr.1 distance to retract when heating</epr>
    <epr pos="254" type="0" value="255">Extr.1 extruder cooler speed</epr>
    </Repetier-Firmware-EEPROM>
  • And why don't you tell us what error you get and during which operation and what exactly you did :-)
  • Repetier said:
    And why don't you tell us what error you get and during which operation and what exactly you did :-)
    G32

    Could not activate z-probe offset due to coordinate constraints - result is inaccurate

  • 09:19:45.847 : Info:Autoleveling disabled
    09:19:50.238 : Z-probe:0.607 X:20.00 Y:0.00
    09:19:53.238 : Z-probe:0.457 X:20.00 Y:45.00
    09:19:56.072 : Z-probe:0.312 X:20.00 Y:90.00
    09:19:58.868 : Z-probe:0.248 X:20.00 Y:135.00
    09:20:01.595 : Z-probe:0.190 X:20.00 Y:180.00
    09:20:05.244 : Z-probe:0.443 X:60.00 Y:0.00
    09:20:08.051 : Z-probe:0.273 X:60.00 Y:45.00
    09:20:10.712 : Z-probe:0.130 X:60.00 Y:90.00
    09:20:13.320 : RequestStop:
    09:20:18.358 : fatal:G32 leveling failed! - Printer stopped and heaters disabled due to this error. Fix error and restart with M999.

  • You need to consider that your z probe is 20mm to the right, so it needs to move 20mm left. Make sure start position is at least x=20 to activate. Also make sure xy area for probing fits into reachable positions with that offset.

    Also which might be more likely here increase z probe bed distance so probe can untrigger when going up. I think your bed is so much tilted that at the next point it was already triggered. 0.13mm distance before that point is not much of a gap to untrigger the sensor.
  • Repetier said:
    You need to consider that your z probe is 20mm to the right, so it needs to move 20mm left. Make sure start position is at least x=20 to activate. Also make sure xy area for probing fits into reachable positions with that offset.

    Also which might be more likely here increase z probe bed distance so probe can untrigger when going up. I think your bed is so much tilted that at the next point it was already triggered. 0.13mm distance before that point is not much of a gap to untrigger the sensor.
    The extruder is above the orange shaded area.

    In the orange shaded area, it does not stick to the plastic tray.

    https://imgur.com/a/CX0ALbt
  • As long as it is not finished with autoleveling it has no effect. You really need to start G32 at a higher Z so it succeeds.
Sign In or Register to comment.