RADDS with TEMP_GAIN 1 results to BED-Temp always 0.0


just tried to install dev-version with the new TEMP_GAIN activated. 
Result was, the Temperature-Reading for the Bed was always 0.0 Degrees and the Bed did not activate. 
Looking in the Eeprom settings, there were new values for the extruder temp-gain and temp-bias but not for the bed.
Using a Radds board and the temp_1_pin for the heated_bed_sensor_pin. 
The Extruder Temp Readings are okey. 

Deactivated the temp_gain and compiled again = Bed works as it should.


  • In extruder.cpp  line 1110 you see
    writeInt(EPR_BED_PREHEAT_TEMP, Com::tEPRPreheatBedTemp);
    writeByte(EPR_BED_HEAT_MANAGER, Com::tEPRBedHeatManager);
    writeByte(EPR_BED_DRIVE_MAX, Com::tEPRBedPIDDriveMax);
    writeByte(EPR_BED_DRIVE_MIN, Com::tEPRBedPIDDriveMin);
    writeFloat(EPR_BED_PID_PGAIN, Com::tEPRBedPGain);
    writeFloat(EPR_BED_PID_IGAIN, Com::tEPRBedIGain);
    writeFloat(EPR_BED_PID_DGAIN, Com::tEPRBedDGain);
    writeByte(EPR_BED_PID_MAX, Com::tEPRBedPISMaxValue);
    writeFloat(EPR_HEATED_BED_GAIN, PSTR("Bed Temp. Gain"), 4);
    writeFloat(EPR_HEATED_BED_BIAS, PSTR("Bed Temp. Bias [degC]"), 4);

    for 1.0.4dev firmware. There you see it writes the bed values after bed PID values. It might not detect you enabling/disabling gain so eeprom gets not initialized unless you reset eeprom with

    Were you using 1.0.3 firmware?
  • I always using dev-firmware. The last version i compiled was from 9th december 2019. 
    For the new config with temp_gain i was using another eeprom-config number so eeprom should have gotten initialized and for the hotend it did. 
    Maybe i will try to activate it again and flash the firmware again with M502 M500 and see if the new eeprom values are then there for the bed. 
    As for now, i was just curious about the feature but had no intention to use it. But was very baffled when the bed-sensor didn't work. 
    But i thought, if anyone else has this issue, i open an thread here.
  • Will test as well next time I use V1 firmware. Just to be sure also I'm quite sure I tested it. But you never know about unexpected bugs.
  • Updated yesterday to the latest dev version. As expected: bed temp is 0° and won't heat up. 
    After a M502 M500 Extr. 1 Temp Bias and Extr. 1 Temp. Gain is there, but no Bed Temp. Gain/Bias. 
    As long as i don't reset the board, Bed Temp is working. But after a poweroff/reset of the printer, no Bed Temp again. 
  • Ok have found the problem and fixed it. When writing it used the address of the extruder offset instead of bed position. So in addition to not storing it, it overwrote an other value as well. Latest dev should have fixed it now.
Sign In or Register to comment.