Hotend not heating


I just mounted an Ulticampy with two hotend and a hotbed.

Board : Arduino Mega and Ramps 1.4

The first hotend well work and heat.
The hotbed work and heat.
Both are well regulated in temperature

The second hotend do not heat. I start to heat and after a fee second it stop by security.

To see if it is an hardware issue I swap the two hotend. Still not working for the second one but the first one work (no issue on hotend and temperature sensor).

After that I change the Ramps to see if the mofset on the board is not dead but still not working.

I change the ARDUINO Mega to see if it is not the output commanding the mofset who is dead but steel not working.

So I have change all the hardware so it should be the software.

The only think that I do not understand is on the Ramps you have leds when the mofset are on.

For the first hotend and the hotbed the leds are bright and nice when the are heating.
For the second hotend the led is very low in brigthnes compare to the two other and it is blinking. Why I do not know????

Do some one face the same issue?
Can you support me?


  • You are using RAMPS board? Disable fan support. Fan is set to same pin as heater for second extruder and only one function can use the pin. If you have a fan configure the fan pin to the pin used for fan.
  • Hello

    Thanks for this support.
    In the configuration tools in the page "Features" I deselect the line "
    Enable fan control (M106/M107) for filament cooling. (FEATURE_FAN_CONTROL)" and it work well.

    Thanks for the support
Sign In or Register to comment.