Z axis won't home or move down

I recently built a 3D printer using a RAMBO board and got it working with Repetier (I found this to be better than Marlin). All axes were moving normally until I adjusted the steps per mm through pronterface. Now the Z axis cannot be controlled by the LCD, and only moves up when I use pronterface. When I try to home, the motors make a really loud screeching like sound until I press the Z min endstop. The endstop isn't triggered from default though, using M119 shows that it is open until I close it as it should be. I've already tried setting an offset but that doesn't seem to work either. 


  • The sound is motor loosing steps. Happens if you move too fast or if acceleration is too high or if motor current is too low. Seems like Pronterface moves slow enough to work. So check eeprom settings and adjust max speed/acceleration to get it working. With changing steps you increased the speed for same feedrate.
Sign In or Register to comment.