REPRAP Discount smart controller lcd not working.

I am using a "Mega 2560" with a "RAPS 1.4" on top of it, though my REPRAP discount smart controller is not displaying anything. The LCD is beeping when I turn it’s encoder, and at one point of random turning and pressing, I was able to move the extruder head. I am using Repetier V092 and loaded it using Arduino 1.8.33. I know very little about using the Arduino IDE or setting up firmware in general. The mega does not have the Arduino logo on it so I am not sure if that makes a difference. Any help would be much appreciated.


  • Check value of FEATURE_CONTROLLER in your configuration.h - it must be 2 - 11 would be the graphic version from reprapdiscount. So watch out to select the right one.
  • Hello,
    I'm new here and I apologize for my English because I'm using the translator.
    I am setting up one myself, "Reprap Prusa Mendel" is already a few years old and just over 1 year ago I started to be able to print mainly with the help of Repetier and this forum that was the most friendly and intuitive that facilitated for me.
    I need and help because I recently bought a ReprapDiscount Full Graphic smart controller instaled in Arduino mega 2560 with ramps 1.4 and I am having, more specifically, 3 problems, being:
    1 - Very dark screen, and I adjusted the brightness in all possible positions.
    2 - SDcard recognizes that it has a card, but it is always empty and there is a message "SDCARD Init Fail". See message.
    3 - Screen does not remain connected without a USB cable and consequently does not work autonomously and without the PC.

    "16:45:33.409 : Free RAM:3668
    16:45:38.520 : SD init fail
    16:45:38.525 : SD initialization failed.
    16:45:38.525 : Do not reformat the card!
    16:45:38.529 : Is the card correctly inserted?
    16:45:38.534 : Is chipSelect set to the correct value?
    16:45:38.537 : Does another SPI device need to be disabled?
    16:45:38.537 : Is there a wiring/soldering problem?
    16:45:38.541 : errorCode: 32
    16:45:38.542 : SelectExtruder:0

  • 1. There is a poti on display for contrast. Apart from this it depends on power it gets on 5V.
    2. You need a FAT32/vfat32 formatted sd card with SPI capability. Not sure how big the card may be. 4GB cards work great normally and are pre formatted correctly. See if other sd cards work. Make sure cable is controller is good. Sometimes one of the wires is not connected. Swap the 2 cables and see if then display is broken and sd card working.
    3. RAMPS has 2 sources for 5V - from mian power via 5V regulator and via 5V usb which is limited to 500mA. So if LCD does not show on 12/24V main power the ramps 5V regulator seems defect. That also makes display darker. When I connect it to usb only it works but with main power it gets brighter from additional power. If you have a voltage meeter measure 5v line without usb connection. It it has no power the ramps is broken. 
  • Good afternoon,
    Thanks for answering.
    I changed the FEATURE CONTROLLER from 2 to 11 without success, and I made a mistake, my ramps are version 1.6 and I didn't find any option for a 5v cover, only the 12v one. I tested SDs of 1, 2, and 4 GB, formatted all of them and put 2 files, 1 STL and another gcode, but the card recognizes that the card has been inserted and does not show any files. Please give me new options.
  • @Juca controller 2 was for sidious who has a different controller. The graphic controller has id 11!
    >  I didn't find any option for a 5v cover
    What do you mean with cover? If you check pinout you will see several pins that have 5V to measure voltage.

    Also did you change cables like I proposed?
  • yes, i changed the cables and he blacked out the screen.
    Do I have to test 5v input or output?
  • 5v output!

    Did you change both ends of the cables? Not that you connected the sd card port to lcd port. If you did it correctly and display is then black the cable seems defect.

  • I don't think I was quite clear what I meant. The screen turns on in any position where the cable is connected, but only in the current position does the information appear. But it turns off when you disconnect the USB cable. in any situation the SD card bed identifies that the card has been inserted, but does not read any files.
  • The 5v output of the ramps to the LCD, provides 2v without USB and 3.9v with USB. On the AUX2 pin of the ramps, it provides 1.9 and 3.8v. :-(
    help me

  • I have 5v outputs from the source that powers the arduino (ATX Source). Can I bridge and connect to the 5v LCD / Ramps?
  • I connected the 5v of the ATX source to the 5v of the AUX3 of the ramps and the brightness was perfect. All other functions worked, except for reading the files inside the SD card. Do you have a specific format or application that you format according to requirements?
  • The official tool is named sdformat I think. What sd cards did you try? Small or big?  As said, not sure if these high capacity sd cards work.
  • I tried 1, 2, 4 and 8gb.
  • ok, then I have no more ideas when power problem is solved. Might be a hardware defect or something I do not see.

    You can try with some examples of and see if it works with the right pins. Just to be sure. That is the library we use for reading sd cards.
  • Problem solved
    1 of the cables was contactless on only 1 pin. I tried to invert but looking at the wiring diagram, I saw that the pin was essential.
    The solution was to buy another cable or repair this one and of course I opted for the immediate one. Very carefully I managed to disassemble the IDC connector and noticed a curved leg. I forced the connection and tested it on the multimeter again and it worked.
    Thank you very much for your attention and assistance.
Sign In or Register to comment.