manual G codes motor does not spin on G1 or G0, does on G28

I use the marlin sofware and a DIY printer.
The motors spin on G28, but not on G1 or G0; Marlin firmware; logging is ok; inside the bed.
any suggestions ?


  • That is more a marlin question. Only reason should be a target position outside allowed region. You should check firmware response in log to see if it shows the reason.
  • The value on the screen turns red if used outside of the maximum defined value in Marlin. The logging however does nog show an error in either cases and the motors will not move.
    Tried with different max values and both on reptier firmware for the printer and marlin firmware

    13:05:47.209 : N12 G28 X0*104 ; G28 manual Home X
    13:05:47.834 : ok
    13:05:49.162 : N13 G28 Y0*104 ; G28 manual Home Y
    13:05:49.771 : ok
    13:05:54.099 : N14 G28*38 ; G28 manual Home
    13:05:59.271 : ok
    13:54:11.700 : N23 G0 X10*97 ; manual is inside max; turns red on the screen if X is outside of X_MAX_POS; no errors in log, no movement
    13:54:11.700 : ok
    13:54:25.825 : N24 G1 Y20*101 ; manual is inside max; turns red on the screen if Y is outside of Y_MAX_POS; no errors in log, no movement
    13:54:25.825 : ok
    #define X_MAX_POS 100
    #define X_MIN_POS 0
    #define Y_MAX_POS 100
    #define Y_MIN_POS 0
    #define Z_MAX_POS 20
    #define Z_MIN_POS 0
  • Please note that red in host means outside dimensions defined in host - these can differ from what firmware thinks.

    Anyhow the moves look legal and should be executed normally. Check with M119 the endstops - if triggered a move in that direction might be blocked. Run M114 before as well to see what firmware thinks where you are. Important for the move direction and hence which end stops would be able to block.
  • Thanks, indeed when outside of the bed the dimensions are red. I checked the endstops and it seems the X as is triggered for some reason. Got the same result with or without a hardware switch and reloading Marlin.

    6:18:39.286 : Resend: N36 M119*31
    16:18:39.286 : Reporting endstop status
    16:18:39.286 : x_min: TRIGGERED
    16:18:39.302 : x_max: TRIGGERED
    16:18:39.302 : y_min: open
    16:18:39.302 : y_max: open
    16:18:39.302 : z_min: open
    16:18:39.302 : z_max: open
    16:18:39.302 : ok
    16:19:11.570 : N37 M114*19
    16:19:11.570 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X: 0.00 Y:0.00 Z:0.00
    16:19:11.585 : ok
  • And triggered means do not move. Having x min and max triggered same time is normally not possible, so your configuration is wrong I guess.
Sign In or Register to comment.