dev v2 connection issue

edited March 6 in Repetier-Firmware
Dear Repetier Dev-Team,
first of all thanks a lot for your work! 
I´m more or less totally new to repetier and Firmwares like this but i managed to adapted the v2 dev to 6axis (what i´m looking for) and manged to build correctly on a due. Adapted the Pins so i don´t need to use a extension board (like Ramps etc) but a Reprap Discount full graphic board. Still not sure if Sd support is running now but my main problem is that i cant get a connection with the board. No repetier Host, Server or Pronterface is working. My Baudrate is correct at 115200 and my Keep-Alive-Interval is 2000 as in you example. I´ve tried to deinstall Repetier Server and Host, also deinstalled the USB Driver... Still not working...
Edit: when trying to connect via Proterface the Arduino is restarting, showing then it´s main menu but it´s connecting. 

Comments

  • First try EEPROM_MODE 0 instead. Sometimes eeprom problems prevent starting. Can be the values cause problem (change eeprom mode then to force reinit) or problems with I2C communication which is blocking.

    Also maybe reduce number of axis. Maximum used my self so far is 5 for a dual x axis where A axis is second X axis. Don't think there are errors appart from maybe a copy and paste error, but you never know. It is important to have it connecting to check for errors, so it's best to start with eeprom and then remove "special" cases that might have introduced a problem until it works again. Then you know which config part prevents it.

    Does display? If it works firmware is not hanging and you might just be using the wrong usb port - due has 2 and normally you have only one configured, also you can configure it to use both so it does not matter which you connect.
  • Thanks. I will try the EEPROM_MODE change! 
    Yes the display works fine, also the encoder and the reset button. Didn´t tried the SD Card so far. In menu all six axis are showing up and are configurable. Du to no use of a tool i don´t need a extruder or equal so i´m not in trouble with motors or Pins. Oh this would be also a Pull Request (even i´m not a programmer and can´t do the needed programming) for having the possibility to set number of tools to 0 without getting a error.
    I´m using only the programmer USB Port. Also tried another Due Board and three different USB wires to be sure it´s not an hardware issue. Also deinstalled all the softwares and the driver etc.

  • You need one tool but you do not need to use the tool. You can add a laser with only a fake output for example. But since it is about a fdm/cnc/laser firmware no tool makes no sense and adds extra cost of testing, also often tests are already there.

    Since lcd works eeprom is not blocking, so check in configuration menu which baud rate is set. Wrong baud rate or port are here the 2 likely reasons for no communication.
  • Tried the EEPROM_MODE change without luck. Baudrate is 115200 in the configuration.h in config meun and in Pronterface. I´m using the programmer Port at the Due. Does Repetier allow to change to the Native Port?
    Will try next week to start from zero and do one change after another while testing. 
     

  • With
    #define RFSERIAL Serial
    #define BLUETOOTH_SERIAL 101

    firmware should be able to connect to both ports, even at same time :-) Just do not print 2 different objects same time.

    But guess restarting and adding block by block would be best idea to see where it stopped working.
  • Don´t ask me why but that was the needed hint! #define RFSERIAL Serial and #define BLUETOOTH_SERIAL 101 was set already so i tied to use the Native USB Port at the Due. This worked! So now, still the Programmer Port just work for Uploading but the Native Port connect to Pronterface. Think i can live with that. Thanks a lot!
Sign In or Register to comment.