Strange Z-Probe behavior with delta

I am trying to set up Z probing on my delta build, and it gives out strange behaviour.

After calibrating towers to be on the same height I am doing G32 S1, and this happens - coordinates gets wierd. Numbers gets too big, and EEPROM value for Z height gets corrupted. After this, any attempt to move results in "Bpos x square error", or A hit floor error (margin is at 1).

G29 gives out fairly normal numbers.

Any tips on this one? 0.92.3 firmware.


  • [ERROR] Error:A hit floor

    Warning:Invalid delta coordinate - move ignored x:0 y:0 z:-2147483520
    Warning:in queueDeltaMove to calculateDeltaSubSegments returns error.
    Warning:moveToReal / queueDeltaMove returns error
    X:0.00 Y:0.00 Z:-48318428.000 E:0.0000
  • I guess some important value like steps per mm are corrupted in eeprom causing computations to give totally wrong values.
  • It is strange, since it was printing ok. I'll tried and moved everything to configuration.h, and re-uploaded firmware, wiping out eeprom - it works now. I wounder what got corrupted.
Sign In or Register to comment.